TB4-UDZ Not Connecting to Dell 7430

Not that long ago, I noticed that the light on my TBT4-UDZ dock was white, not green. Didn’t know what to make of it, but could still reach my USB hard drives. Network was connecting via wireless, not the dock.

Yesterday, woke up to a dead laptop.

Unplugged the dock and plugged in the brick. Laptop started, checked out.

Tried plugging the dock back in. No power; laptop stayed on battery. White light started blinking slowly. Unplugged everything else from the dock; no change. Looked at Device Manager. Appeared that the blinking coincided with an attempt to connect to one of the three “superspeed” USB Ports.

Restarted laptop. Now, dock makes no attempt to connect when plugged into the laptop. Device manager shows no “superspeed” USB ports. USB4 Router reports device working. White light on, not blinking. No connection. No power charging. Nothing.

This really throws a hitch into my workflow.

Do I need a replacement dock?


Additional info. Plugged the dock back in after filing the initial topic. Now, it is blinking from white to green, while the laptop beeps something connected, something disconnected.

Hello Jade,

Thanks for contacting us about this issue. I’m sorry to hear about this problem with the dock.

Please note that we received a direct email from you yesterday and have replied to you there directly earlier today asking for additional information.

I look forward to your reply via email and will be happy to get this problem resolved for you.

Thank you and best wishes,

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies


I replied with the information you requested as an addition to the support ticket and received a receipt for that addition at 5:06 PM yesterday.


1 Like

Solved! Replacement coming. Thank you, Plugable!!


1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.