Surface Pro 4 using ud-3900 max out around 300mb not getting 1 gigabit download speed


#1

Love my Plugable devices. have around 25 of them for my companies. However I ran into a problem as I just updated my home network to 1 gigabit speeds. Techs left my house getting 985 mb download. However I can not get my SP4 connected to the ud-3900 to get over 300mb. I actually had the same problem when my speed was at 400mb from my ISP.

I am just worried my plugable ethernet driver is not configured correctly? Even if I plug it directly into the router I am not getting the speed. With the SP4 there is not network plugin of course so I use a Microsoft 1622 adapter to plug directly in. However it still uses your driver i believe.

I have gone into the Ethernet driver and switched it over to 1 gig full duplex but that didnt seem to increase the speed. Well maybe the first time after doing so it increased it, but could have been a fluke.

Before you ask all my network cables are cat 6. I have swapped out to make sure that is not an issue.

I ran the plugdebug and have the results ready to email


#2

Hi Sam,

Thank you for posting, and I would be happy to help with your docking station!

Thank you as well for the detail you provided and the testing you have performed that is much appreciated.

A quick question for you in regard to your statement, “With the SP4 there is not network plugin of course so I use a Microsoft 1622 adapter to plug directly in.” I am not familiar with the Microsoft 1622 adapter you mention. Can you provide a web link to the specific product you are using?

I ask because to the best of my knowledge no Microsoft networking product uses a DisplayLink-based Ethernet adapter like the one inside of the UD-3900. As a result, the Microsoft adapter is most likely using a different software driver. Given that the Microsoft Ethernet adapter appears to exhibit the same problem in your testing, I would like to review the Microsoft unit’s specifications online so I can be certain of any differences.

Thank you,

Bob
Plugable Technologies


#3

This is the network device I meant. Microsoft USB 3.0 Gigabit Ethernet adapter 1663

Can you give me a ticket so I can send you my output from the plugdebug results


#4

Hi Sam,

Thanks for getting back with the update, and I appreciate the clarification as to which specific Microsoft Ethernet adapter you are using.

I did some digging, and the Microsoft Surface USB 3.0 Gigabit Ethernet Adapter you are using is based on a Realtek Ethernet chipset. This is a completely different chipset compared to the DisplayLink chipset within the UD-3900, and the Microsoft adapter will use a completely different Realtek software driver. The DisplayLink network driver will not affect the performance of Realtek network driver.

Given the differences, in an effort to help isolate the behavior further may I ask you to test in the following manner?

  1. Disconnect the UD-3900 dock from the Surface Pro 4 and put it aside temporarily (we won’t be using it at all for this test).

  2. Connect the Microsoft Surface USB 3.0 Gigabit Ethernet Adapter directly to the single USB 3.0 port built-in to your Surface tablet. There should be no devices ‘in-between’ the two, such a USB hub.

  3. Connect one end of the Ethernet cable to the Microsoft Surface USB 3.0 Gigabit Ethernet Adapter, and the other end directly into your cable modem. We do this to remove the network router as a contributing factor.

  4. Test the network speed again and record the result.

Based on your original description it sounds like you may have already tested in this manner, however I just want to be sure I have the details correct hence the explicit instructions. This is important because if the network performance using the Microsoft Surface USB 3.0 Gigabit Ethernet Adapter directly connected to the Surface Pro 4 is also lower than expected in the above configuration, that will effectively rule out the UD-3900 dock and the DisplayLink driver as a contributor to the behavior.

Thank you,

Bob


#5

Bob,
Thanks for the quick response. Yes sir I actually did the test you recommended going directly into the modem again last night. I got the same slow speeds. The technician from Spectrum said he never saw a person get over 500 on a Surface computer. So either using the Microsoft or the UD-3900 I can’t get over 400. However those speeds are just a burst for me and then my speed test drops down to 200 or less. I am using several different websites for the test by the way choosing testing sites that are close my location.

So I guess it’s a driver issue with both devices or some other setting perhaps. I was just hoping with your expertise you might be able to point me in the right direction. I have been googling everywhere and can’t find anyone discussing this issue.

Also I think you worked with me 2 years ago when I had an issued with my devices at my office. It was a 4k television issue and you had me move from the ud3900 and go straight with a Hub and adapters. Thanks again as that is still working great!

Thanks in advance for all your help. Also I still need a way to email you the zip file from the output from when I am using just the Ud-3900 (not the Microsoft in the mix.)

Sam


#6

Hi Sam,

Thank you for getting back, and you are most welcome for the help.

Thank you as well for the confirmation that the problem also occurs when the Plugable dock is not in use, I appreciate you taking the time to test in that manner. I believe you are correct in that I helped you back in August of 2016, and I am glad to hear that the alternative solution I recommended in that previous case is working well.

To the issue at hand, that the problem behavior occurs with the Microsoft Ethernet adapter (when our dock is disconnected) confirms that the source of the problem lies somewhere ‘outside’ of our product. That the Spectrum technician indicated that other Surface users encountered similar problems is interesting, however I am afraid I cannot explain the cause and would be hesitant to hazard a guess given all of the variables at play that we cannot control.

While we typically are not able to help troubleshoot network issues that lie outside of those related directly to our products, I would be happy to examine a PlugDebug file from your system as a courtesy to see if anything obvious jumps out (however I can’t make any guarantees we will be able to offer a solution).

Please just send the file to us directly via support@plugable.com with 'For Ticket #239647" in the subject line so we can match everything up. * Please do not post the file in our public forum *

Thank you,

Bob


#7

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.