Surface Pro 3 - Plugable UD -3900


#1

I have recently bought a plugable UD-3900 USB 3.0 with dual monitor functionality and I have installed the drivers on the Device( Surface Pro 3) and on the display options I can see the HDMI dislpay as being available, However, It does not display anything. Even if I make it my main screen


#2

Hi Gavin,

Thanks for posting! I’m sorry the docking station isn’t working properly with your Surface. I’d be happy to help.

The first thing to make sure of is that the DisplayLink drivers for the dock are installed correctly. We’ll want to clean the current drivers from the Surface and re-install the latest we recommend. Pleas follow these steps:

  1. Disconnect the dock from the Surface and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step

  3. Download, extract and run the DisplayLink cleaner tool, found here:
    http://displaylink.com/support/sla.ph…

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and run the 7.7 M4 DisplayLink software, found here:
    http://displaylink.com/support/sla.ph…

  6. Reboot, even if not prompted to

  7. Once you’re back in Windows, reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your Surface which will trigger the final portion of the installation

Hopefully the driver re-install gets everything going. Let us know the results when you have a moment and we can determine the next steps from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3