Suddenly Not Recognizing Dual Monitors (Two Plugable Docking Stations)

I purchased my first Plugable 3.0 docking station about a year ago for my home and it has been working perfectly until now. I just purchased my second Plugable 3.0 docking station to use at my office. I was able to set up my new office Plugable no problem. But now, my original docking station is no longer recognizing my monitors at my home set up. I am using the same laptop for both docking stations.

We resolved this problem via email. For anybody else having similar issues this was the resolution. Please feel free to email us directly: support@plugable.com

Our resolution was to reset the dock and perform a ‘clean’ installation of the required DisplayLink drivers to help ensure both were in a good state. By performing the following:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download and run the DisplayLink Installation Cleaner utility, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.4 M0 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system. If the device is not detected, please reboot the system.

Pat
Plugable Technologies
www.plugable.com/support