Soundcore Liberty Air (Earbuds) Issue


#1

Just recently purchased a pair of Anker Soundcore Liberty Air earbuds to use with my Windows 10 desktop and my Pluggable BT adapter.

I’ve been using this BT adapter for about 1 month now, no issues, but for whatever reason, these earbuds simply will not reconnect without manual pairing.

From the start, pairing works perfectly fine, and once they are paired and remain powered on, everything works. Once I turn off the earbuds/put them in the charging case, which turns them off as well, they will not reconnect, no matter what I try, when powering them back on.

The only thing that will get them to reconnect, is to delete their paired entry, then re-pair them again.

Testing these same earbuds with a Dell Windows 10 laptop, with it’s internal BT device and my mobile phone, the issue is not present, they work as intended on those other devices.


#2

Hello,

Thank you for posting on our forum. I’m sorry about the problems with pairing the earbuds again after turning them off. We have seen this behavior with other audio devices in Windows, and are not 100% sure why it happens. Could you please answer a couple of questions about your setup that will help me better understand the issue?

  1. Is Windows 10 at the same version on both the desktop and on your Dell laptop?

  2. Did you download the drivers from the Plugable website, or did you let Windows automatically install the driver? Please don’t change whatever situation you are currently in, we will troubleshoot from there.

Thanks!

David
Plugable Support


#3

Yes, both devices are on the same OS SKU and updates/version. See below.

Desktop
Windows 10 Pro
Version 1809
OS Build: 17763.316

Dell Laptop
Windows 10 Pro
Version 1809
OS Build: 17763.316


#4

Thank you for your response. I was wondering if you could tell me whether you downloaded the files directly from our website or if you let Windows automatically download them from the Microsoft server. It help me know the version of the driver.

Also, it would be helpful if you could run our our diagnostic program on your desktop computer. It will gather device information and installation logs that will give better understanding of what other drivers are coming into play.

To do this, please plug the adapter into your computer, then go to this page, and follow the instructions there:

http://plugable.com/support/plugdebug

In order to maintain privacy, please sent the resulting file via email directly to our support@plugable.com address instead of posting it here.

Thanks!
David
Plugable Support


#5

Sorry forgot to mention about the drivers.

I tried both ways, allowing Windows 10 to auto install from the driver store, and I tried removing that driver and reinstalling with the latest version on plugable.com. Both factored the same result.

I will run the tool as well, and provide the info.


#6

Thanks!

Please let me know when you send the file.

David
Plugable Support


#7

I have submitted the log .zip via email, as requested.


closed #8

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.