Some programs don't render properly.


#1

Hello,
I have
"Plugable UGA-125 USB 2.0 to VGA/DVI/HDMI Adapter for Multiple Monitors up to 1280x1024 / 1440x900 Each - DisplayLink DL-125 Chip Plugable UGA-125 USB 2.0 to VGA/DVI/HDMI Adapter for Multiple Monitors up to 1280x1024 / 1440x900 Each - DisplayLink DL-125 Chip "

The product works really great for me and I love it. However, there is on program “Visual Studio 2010” that doesn’t seem to render properly on my second monitor. I believe because it’s WPF based. Any ideas or suggestions on fixing that issue?!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0j1dl6i_MrTGKaBAvq0On8JS0spvJZgq03t65bQrSrWgJ3KMeKU0wJGC0rwkwfP6xQ==.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/351160/Capture.PNG)


#2

Hi - Thanks for contacting us and for posting the screenshot of the problem!

It looks like you’re on Windows 7, is that correct?

Yes, VS 2010 is a WFP application, and that creates some special demands on the graphics subsystem. (e.g. WPF applications failed entirely on Windows XP up until DisplayLink driver version 5.5 dated Sept 29, 2010).

First thing I’d recommend is to install the latest DisplayLink drivers, which are 5.5 M1 (Dec 3), available here: http://displaylink.com/support/downlo…

If that doesn’t solve the problem, can you post what primary GPU your system has (nVidia/ATI/Intel, and what model)?

Thanks for your patience while we get this figured out!
Bernie


#3

Thank you for prompt response, I installed the updated drivers but that didn’t seem to fix the issue. The display adapter I have is:
NVIDIEA Quadro NVS 150M

hope that helps.

thx,
Cal


#4

Hi Cal,

I’m very sorry, as far as I can tell this appears to be a DisplayLink/nVidia driver interaction causing these rendering issues with VSTS 2010. It’s the first report we have of it (and I’m running VSTS 2010 here without this issue, but on Intel GPU).

Long-term, what we’re going to do is report the issue to DisplayLink and track getting a fix in a future DisplayLink driver version.

In the short term, I’d still like to find you a workaround. Can you tell what nVidia driver version you are running? If it’s a version later than 258.96 (July 19, 2010), would you be willing to go back to an earlier version?

This nVidia driver version (258.96) may avoid problems in later nVidia drivers:

32-bit: http://www.nvidia.com/object/win7-win…
64-bit: http://www.nvidia.com/object/win7-win…

If you do go to that version, can you let us know if it helps?

More manual workaround suggestions are to max/min the application when rendering problems happen, and/or keep VSTS on the primary screen, and use the secondary USB screens for other applications.

In order to gather some data for filing the DisplayLink bug, would you be willing to run the DisplayLink Debug log collection tool (http://www.displaylink.com/support/ti…), turn on advanced logging, reproduce the problem, and email the generated log .zip file to support@plugable.com? Thank you!

Again, my apologies for stumbling on this rendering problem Cal. We’ll work towards a long-term solution.

Thank you!
Bernie


#5

Bernie,
No reason to apologize at all, I’m using VSTS2010 on my primary screen, so it’s not blocking my work. I’m very satisfied with the application and with the exception of VSTS very thing else works as expected. I’m anticipating to upgrade my laptop soon, so it’s probably not worth it to spend quiet much time on it.


#6

Happy to know that! Well, if you get a chance to generate those logs, please just go ahead and send them - we’ll get things started. If you don’t have a chance, no problem. Thanks so much for your purchase and your patience!

Bernie


#7

The most recent update has solved this issue, Thank you guys you ROCK!!


#8

Just for the benefit of others, it was the just-released DisplayLink version 5.6 driver that solved the issue - is that right? Awesome to have you running without problems here. Thanks so much for your patience!


#9

Hello - I’m having the same exact issue (please see attached).
I’m running with DisplayLink driver v 5.6 M1. My GPU is Intel Integrated (HP laptop EliteBook 6930p).

Unfortunately since the DisplayLink monitor is my main monitor, this is a quite a serious issue for me (I’m just switching to working with VS2010 and moving back to VS2008 is not an option).

Your help in resolving this issue is greatly appreciated.

Regards,
V.K.

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0tI-il8rTQjv1sdH5KunGuZDwt9JfJOS551rcJGZxROhen-HZ3lS3PGaF4JDP-aINg==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/487360/VS2010.png)


#10