Some Midi devices not recognized if using USB hub.

I just got a Plugable USB 3.0 7-port hub with dual charging ports and have connected it to my iMac Pro. I plugged in 6 MIDI controller devices. Four of them are working. But I have two Evolution U-Control UC-16 MIDI controllers that do not show up on my Mac. They do show up if I take the same cable out of the Plugable hub and plug it directly into the Mac. What’s the problem?

Also, I pressed ‘start’ on Plugdebug but it never wrote a file to my Desktop.
In Terminal, top shows that it is sleeping.

Hi James,

Thank you for your post! I’m sorry you are seeing intermittent performance with our hub and you MIDI devices. I would like to help you troubleshoot this!

The PlugDebug failure is concerning, but we can start with a System Profile report! I have instructions below on how to find this.

Please have the Hub plugged into your Mac with all MIDI devices plugged into the hub as you normally would use them for the purposed of this report.

  1. Click on the Apple symbol in your menu bar and select About this Mac
  2. In this window click on System Report and this will open the System Information program
  3. In this program, please click File > Save and in the Save As field type “212529” and save this to your Desktop.

Please send that file to with “Ticket #212529” in the subject line and we will take a look to see what is going on!

Thank you,

Derek Nuzum
Plugable Technologies

done and sent.

Hi James,

We’re going to close this thread as we found an answer and solution that worked for you! Unfortunately, MIDI devices can be particular in how they are connected to the host system and these devices did not want to be connected via our USB hub. Luckily, everything else worked so you are good to go.

Please let me know if you need any further support at any time by reaching out to and we would be happy to help!


Derek Nuzum
Plugable Technologies