(Solved)Detected USB 2.0 Microscope as audio device windows 10


#1

Shows up under Sound Video and game controllers in device manager as (USB Microscope) on selecting property details Value Usb Audio device. not being detected by plugable digital viewer. tried the update driver from my computer (pick from list of drivers but only get option of Usb audio device no selection for usb video?

(Edit) device dosnt seem to be at fault as tested on my brothers linux laptop it works. just cant make it work on my windows 10 pc


#2

Hello,

Thanks for contacting us! I do apologize for any trouble you’ve had with our microscope, and I’d be glad to help! Do you have an Oculus Rift headset? The reason I ask, is that the microscope uses the same chip-set as the Oculus sensors making the system believe it is another Oculus Sensor.

If you have an Oculus Rift I would suggest to try these steps:

  1. Disconnect the Oculus Rift sensors and cameras.
  2. Connect the Plugable USB Digital Microscope.
  3. Open the Device Manager in Windows. This can be done several ways, if you’re uncertain how to access Device Manager perform these steps:
    • Press the Windows key and R (Win + R).
  • In the window that pops up, type “devmgmt.msc” (without quotes), then click OK.
  1. Look for the microscope. It will likely be listed as a Rift DK2 sensor, under ‘Oculus VR Devices’. If you’re not certain if you found it, disconnect the microscope and the entry should disappear. Reconnect the microscope and the entry should come back, that’s how we’ll know for certain we’re looking at the correct device.
  2. Once we’ve found the microscope, right click on it. Choose ‘Update Driver’ > ‘Browse My Computer For Driver Software’ > ‘Let Me Pick From A List Of Device Drivers On My Computer’, then look for ‘USB Video Device’, then click next to complete the install.

Please note, after completing these steps, Windows will still name the microscope as ‘Rift DK2 Sensor’. To confirm these steps worked, look for an entry for Rift DK2 Sensor under Imaging Devices (if the steps did not work it will be listed under Oculus VR Devices still). The user will need to select ‘Rift DK2 Sensor’ to use the microscope in Plugable Digital Viewer or other applications. I hope this helps!

Thank you,

Kevin
support@plugable.com


#3

i do have a oculus and was exactly my issue working fine now thank you its now listed under cameras and it also renamed from dk2 device to USB Microscope also obs studio is now detecting it as a camera ahd displaying as should.


#4

Hello,

Thanks for the reply! Ah, I see. Awesome, so everything is working now it seems? Glad to hear it. If anything comes up, please just let me know and I’ll be ready to help. Have a great weekend!

Thank you,

Kevin
support@plugable.com


#5