SolidWorks will not start

My SolidWorks will not start after switching over to the USB-C 4K Triple Display Dock from the Dell WD19 130W dock.

My setup is Dell 5520 with Quadro M1200 and three Dell U3219Q displays.

The Dell WD19 130W dock I was using can only provide 4K@30Hz for the two displays on DP and a fuzzy 1080P@60Hz on the display with HDMI. So I switched over to the USB-C 4K Triple Display Dock and it provided 4K@60Hz for the two displays on DP and 4K@30Hz for the display on HDMI.

All good and goal achieved except now my SolidWorks 2020 SP4.0 will not start and won’t load beyond the initial splash screen. I have already installed the DisplayLink driver and SolidWorks still won’t start. Switching back to the Dell dock and SolidWorks will load and works perfectly.

Anyone knows how to make the USB-C 4K Triple Display work with SolidWorks on the Dell laptop?
Please help.

Hi JT,

Thanks for posting!

Based off the description of the issue, we have seen similar problems with other applications that use OpenGL such as Sketchup.

To be more specific, Windows can mistakenly direct tasks intended for the system’s internal graphics adapter (which does support OpenGL) to the DisplayLink-based docking station. Our docking station is not a traditional graphics adapter in and of itself (it relies on the CPU and internal graphics adapter to work), and this results in the incorrect behavior or error message.

There are a few possible workarounds. The first is to have the main display assigned to a display directly connected to the internal graphics adapter – whether that is the internal laptop display or the external monitor connected to the “HDMI 4K” port on the dock. Video instructions for doing so can be found on our YouTube channel:

Another workaround which we have seen success with is to navigate to the “OpenGL Rendering GPU” settings in your Nvidia Control Panel application and force it to choose the Nvidia GPU instead of “Auto select”.

Lastly, an application-specific workaround may be possible by investigating the setting of Solidworks to see if you can disable any kind of “OpenGL hardware acceleration” setting. This setting does appear to exist according to this article:

Could you please let me know if any of these workarounds is successful in this specific case? We can best take the next steps from there.

Thank you for giving us a chance to help!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.