slow internet display with my Plugable 2.0 docking station


#1

I don’t have the windows update installed that you said is an issue, yet I still have slow display when browsing the internet through my Plugable 2.0 docking Station.

I’m running windows 7 home premium and I have the follwing KB’s installed: KB973923, KB973924, KB973688 and KB954430.

Is there another fix?


#2

Hi Tom,

Thanks for posting. Sorry for the frustration! First thing we’d recommend for a sluggish web browser is to turn off hardware acceleration within the browser settings.

The reason why this non-intuitive step often helps, is because browsers have in recent years changed the way they do graphics to assume a high-power (PCIe attached) hardware GPU. But when that isn’t the case, they render much slower than they used to. Turning off “hardware acceleration” tells them to do things the simpler way, which works more consistently (including for USB graphics).

Can you say what web browser you use primarily? We can reply back with the browser-specific way of changing that setting. And if that doesn’t help, we can look for other, less common with some diagnostics. Just run the tool here:
http://plugable.com/support/plugdebug

And email the resulting .zip to support@plugable.com.

Thanks for your patience while we help!
Bernie


#3

hi. Sorry it took so long to get back to you… I checked my browser and I’m running IE11. Specifically, 11.0.9600.16476. It also mentioned an update, 11.0.2 (KB2898785). I’ve also sent the Log file from my home computer that has both my work and home email address.

Thanks for the help.


#4

Hi Tom,

Got it,thanks! Could you go into IE11’s settings, and configure it to use software rendering? That can actually improve performance. Here’s how:

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1006380/ie11-use-software-rendering_inline.PNG?1389041251)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1006380/ie11-use-software-rendering.PNG?1389041251)

Thanks for letting us know how that goes!
Bernie


#5

That worked! Thanks very much!


#6

Wonderful! Thanks for letting us know!


#7

Hi Bernie. Seems I have another issue with my docking station. I just installed TurboTax 2013 and the application will not render when I have my docking station hooked up to my laptop. Any idea what could be going on?


#8

I have Turbo Tax 2012 loaded as well, and it does almost the same thing… The difference is that only part of the screen renders.

I do have Quicken 2012 installed and interestingly, that software seems to render fine. Both are Intuit products.


#9

Hi Tom - it’s likely Intuit is using different APIs for the two apps. Most likely WPF for TT 2012.

We may not be able to solve it, but to give a shot on the assumption Turbo Tax 2012 is a WPF app, could you open notepad, and save the text below to a file called something like wpf.reg

Then find wpf.reg and double-click it to apply the registry change.

This should disable use of DirectX for WPF apps, which may help.

Thanks!
Bernie

Here is the 3 lines of text to put in that file:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Avalon.Graphics]
“DisableHWAcceleration”=dword:00000001


#10

Thanks for getting back to me. Before I do this, is there a backout for this change in case it affects other functionality on my PC?

Is it as simple as re-executing the file with “Disable” replaced with “Enable”?


#11

Hi Tom,

It’s the Windows registry, so some caution is called for. But, undoing is simply changing the dword:00000001 to dword:00000000

And re-running the .reg file.

Since this is just for a narrow case (getting a certain app to behave better when shown on the USB attached display) – would totally understand if you’d want to stick with status quo. But either way, I hope knowing the option is there helps.

Thanks!
Bernie


#12