Self-Assigned IP error

Plugable, help here is appreciated again:

re: Self-Assigned IP error with my MacBook Air docking with my UD-CAM

I believe I have now read all the related self-assigned IP error topics, and still having the connection issue randomly for the last month, thanks in advance. Symptoms:

1.) All non-Apple computers connected on my home network are working fine (including 3 Chromebooks, a windows PC, and a windows Surface tablet) all online at same time.

2.) With my MacBook Air I get the typical error message greeting when I wake up in the morning to work via ethernet:

“Ethernet has a self-assigned IP address and will not be able to connect to the internet.”

Based on the number of posts on this, it appears it is very common for the Mac, but it’s possible many people are resorting to hotspots and shotty wifi connections, chasing the problem and jumping network locations when it happens, not solving the base ethernet / UD-CAM connection issue.

3.) I have tried the following the common “6 troubleshooting tips” which are posted many places online, multiple times and nothing has worked:

  1. Reset your network preferences on Mac
  2. Renew DHCP lease on macOS
  3. Create a new network location
  4. Reset the firewall on your Mac
  5. Set Service Order from Mac’s Network settings
  6. Change DNS servers on macOS

4.) Additional info - I have structured ethernet around the house, and when I try another jack, 50/50 chance it works. Same switch different day… different jack will have the error, very inconsistent for the Mac, again no problems with Chromebooks.

5.) LMK if you would advise I also run PlugDebug for you.

Would love a solid fix with my Mac + UD-CAM inline, thx !!!

Hi Sam,

Thank you for posting! I am sorry your docking station is not working as expected and I would be happy to help.

Thank you as well for the detail you provided and the testing you have performed that is much appreciated. Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug → http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 397479’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

Hi Sam,

Thank you for reaching out to us directly! I would be happy to provide support via email ticket #397602 going forward.

Thanks for your patience while we work to help!

Ryoma
Plugable Technologies
www.plugable.com/support