Seiko Smart Printer 220 port problem


#1

I have a Seiko Smart Label printer, model 220, that has been working great–with my old desktop. I want to use it with either my Compaq Presario V6000 with Windows XP or my HP desktop with Windows 7.

Advised to purchase a converter, I bought a plugable USB serial converter, but neither computer recognizes the printer. I.e., I can get to the point of creating a label but when I try to print, the message “Can’t initialize port LPT1” displays. I have tried to change every setting in the SLP software, but nothing works.

Can you help?
Thanks, Ellen


#2

Hi Ellen-

Thanks for contacting Plugable support, I’ll be happy to help. You won’t be able to use LPT ports (parallel ports) since this is a serial connection rather than parallel.

I found instructions below on how to configure Seiko printers at: http://www.siibusinessproducts.com/us…

Q: How do I set up an SLP to print by serial? A: Do the following:
From within the Start Menu -> Control Panel -> Printers & Faxes
Double click “Add Printer”
Select a serial port. Usually COM1. (It may be COM2 through 4 if you have more than one serial port on your machine.) Push Next.
Turn off the “Automatically detect Plug and Play” checkbox.
Scroll to the end of the Manufacturer list and select “SII”.
Select your printer model from the “Printers” list. Push Next.
Keep existing driver. Push Next.
Give the printer a name. Push Next.
OPTIONAL: If you want to use the printer instance to print by SLP, turn sharing on for the printer. Push Next.
OPTIONAL: Enter location and comment.
Do NOT print a test page. Push Next. (Test pages are for legal paper and don’t work right for small labels.)
Push Finish.
After the new printer appears in Printers & Faxes, right click the printer and select the “Properties”.
Click the “Ports” tab.
Select the COM port you chose in step 3.
Push “Configure Port” and change the settings as specified below:

SLP 440 or SLP 450: 38,400 Bits per second
SLP 410 SLP 420, SLP 430: 57,600 Bits per second

For all printers:
Parity: None
Stop bits: 1
Flow control: Hardware

If you change the speed settings, BE SURE to check other properties as well. Windows will sometimes reset them without warning.

Try to print from Notepad. If serial printing does not work, verify all of the settings above, especially the settings in step 15. Otherwise, you could have a bad cable, serial port, or printer.

I hope this helps, but please let us know if you’ve any other questions.

Best wishes-

Jeff Everett
Plugable Technologies


#3

Sorry, this didn’t work. Printer model is 220, and the control panel dialog is not what I see on my computer. Help?


#4

Hi Ellen-

I double-checked Seiko’s link and found these settings relevant to your model:

Q: What are the built in connections on my Smart Label printer and what rate do they communicate?
A: The SLP 100, 120, 240, 410, 420 430, 440, 450 all have both built-in USB and Serial connections. The USB port is USB 2.0 Full Speed. The serial port uses a RS-232 cable and communicates at the following speeds:
SLP 120, 220: 9600 baud

It would also make sense to double-check what Com port has been assigned to our serial adapter since this is the Com port you’ll need to set the printer to. Steps on how to check/change a Windows Com port are here: http://plugable.com/2011/07/04/how-to…

Please let me know if trying this baud rate and double-checking your Com port helps. If not perhaps you can reply with a screenshot of whatever error you see?
http://windows.microsoft.com/en-us/wi…

I hope this helps, but let me know if you have other questions!

Best-

Jeff


#5