Second Plugable USB 3.0 Dock Doesn't See New Drive


#1

I bought a second Plugable 3.0 Dock and got it today with a WD 1 Gig Caviar Blue Drive.

I have an initial drive (same model) that I used on the first one. I encrypted it with Truecrypt.

I tried the new drive in both Plugable Docks I have and nothing happens in either one. Does this mean I got a bad hard drive or is there something else I’m missing?

I’m pretty sure the last drive I put in was recognized almost immediately and Windows 7 asked if I wanted to initialize it.

Any help would be appreciated.


#2

Hi Doc,

Thanks for posting! Just to confirm - the old drive works on both docks, the new drive works on neither - is that right?

There isn’t a reason to expect particular drive incompatibility, so we’ll try to rule that in/out next …

Thanks for confirming, and we’ll figure out next steps …
Bernie


#3

The old drive works on both. Initially it kept disconnecting over and over (on the new one) and Windows said I should use a USB 3.0 port (which I was), but now both docks seem to be working fine with the old drive.

The new drive doesn’t work on either dock.


#4

I solved my own issue.

I needed to do this first:

http://wdc.custhelp.com/app/answers/d…


#5

Hi Doc,

Glad you’re up and running! Let us know if any other questions come up - it’s great to have you using multiple SATA docks there on that machine.

Best wishes!
Bernie


#6

Thanks Bernie.

Here’s a snapshot. !](https://s3.amazonaws.com/satisfaction-production/s3_images/575976/IMG_0676-1_inline.JPG)](https://s3.amazonaws.com/satisfaction-production/s3_images/575976/IMG_0676-1.JPG)


#7

Cool! It’d be neat to get that up on Amazon where lots of people would see it. Here’s the link to do that (specific to the product): http://www.amazon.com/gp/customer-med…

Thanks again!
Bernie


#8

So, once you contacted WD, what was the fix? Nicw picture.
Lawson Stevenson


#9

Lawson,

If you go to the customer service link at WD it explains the process…
http://wdc.custhelp.com/app/answers/d…

Essentially you need to initialize the hard drive before it will show up under your drives. I did it the first time but forgot about that when I got the second Plugable.


#10