Sandisk USB drives not seen

I have a few Sandisk usb drives that are not recognized using this hub.
I can plug it into the computer directly just fine but nothing on the hub. I’ve tried other usb drives in the same port so I know the hub is working.

These drives show as usb 3.2 gen 1. Is there a known issue with 3.2?
I’ve tried the following Sandisk USB drives:

Also to note, I have tried this on multiple computers with different operating systems.

Hi Scott,

Thanks for reaching out to Plugable support! I’d be happy to help with that.

I don’t see any reason why this should not work with the USB hub, however, have you tried testing these with the hub individually or are they all not working when connected together?

Thank you,

Richard A
Plugable Technologies

I have tested the hub on multiple computers with a variety of drives. I have 2 of the hubs and they both are behaving the same way.
Quite a few of the other model drives work just fine on the hub.
I have tested the drives one at a time, both using the hub and plugging them into the same port I am plugging the hub into.
The Sandisk usb sticks in question work when plugged directly into the computer, but are not recognized when I plug them into the hub.

It is rather odd that all other devices seem to be working except for these particular thumb drives. You may be able to get a better explanation as to what’s going on by contacting Sandisk however, we’re definitely willing to look into anything that could stand out preventing it from connecting.

The next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug → to us directly via with ‘For Ticket 388531’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Richard A
Plugable Technologies

Thanks for the help. I’m only going into the office a couple times a week right now so I can’t check right away.
I’ve also read a case that some Sandisk USB drives aren’t recognized in some ports when fully inserted, but work when partially inserted. Looks like a possible mechanical flaw in their design.
That might explain why they work in the computer port but not the hub.
I’ll test this, as well as run the diagnostic the next time I’m in the office.

Hi Scott,

Thanks for the update.

Richard A
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.