Same speeds as 10/100 controller


#1

Why am I getting the exact same results that won’t exceed 100MB download speeds from the Plugable USB 3.0 10/100/1000 Gigabit Ethernet Adapter as I was getting with the built in Realtek 10/100 controller, yet other computers with Gigabit controllers are getting substantially higher than 100MB download speeds on the same network?


#2

Hi Todd,

Thank you for posting. I’m sorry there have been issues with getting the full available speeds through your USB Ethernet adapter, and I would like to help.

To start, I would like to ask a few questions to get a better idea of how things are set up. Please answer the following:

  1. What operating system is running on the device that the USB Ethernet adapter is attached to?

  2. Regarding the Ethernet cable plugged into the adapter, it should have information printed on it that indicates what category it is. It might say “Cat5”, “Cat5e”, or “Cat6”. What is printed on the cable you are using?

  3. Are you connecting to a home network, or is this at a school or workplace?

I look forward to hearing back.


#3

Hi Seth,

This is being used on a Dell Inspiron i17 laptop with an Intel Core i3 1.9GHz processor running 64-bit Windows 10 on my local office network with Gigabit firewalls/routers/switches and mostly Cat 6 cabling with some Cat 5e. Although this laptop isn’t that old it does only have a 10/100 network controller which is why I got the Plugable device. I have other Dell laptops in the office that already have a built in 10/100/1000 controller and if I hook it up to the same network cable it gets the higher speeds. Also, I have 2 of the laptops with the 10/100 cards so I actually bought 2 of the Plugable devices and have tried both of them to see if it was a faulty device but got the same result with both devices on both laptops. I get virtually identical speed test results whether using the built in 10/100 controllers or the Plugable 10/100/1000 devices. Hope this helps.

Thanks,

Todd


#4

Hi Todd,

Thank you for answering those questions and providing additional information.

It sounds like everything on the network is as it should be, but the adapter may be negotiating a 100 Mbps link speed for some reason. I would like to check some information on your system to see if that’s what is occurring. Please do the following:

  1. Right-click the Network icon in the system tray in the lower-right, and select “Open Network and Sharing Center”.

  2. Select “Change adapter settings” in the left column.

  3. Right click on the device named “ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter”, then select “Status”.

  4. In the status window, it should indicate the Speed; please make a note of the value it lists or take a screenshot.

  5. Open a Command Prompt window.

  6. Type the following command, then press enter:
    ipconfig /all

  7. Either copy the text that appears in the window, or take a screenshot.

Please send me text output / screenshots gathered in steps 4 and 7.


#5

Here you go

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1643975/Screen1_inline.JPG?1504281156)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1643975/Screen1.JPG?1504281156)

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1643976/Screen2_inline.JPG?1504281173)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1643976/Screen2.JPG?1504281173)


#6

Hi Todd,

Thank you for sending over those screenshots.

The first image shows that the adapter currently has a link speed of 100 Mbps, which is definitely what’s causing of the problem. The adapter is capable of gigabit link, but the throughput will be limited to 100 Mbps so long as the link speed is set to this lower value.

Normally network adapters are all set to “auto negotiate”. This means that when 2 Ethernet adapters are connected, they automatically set themselves to the highest link speed that both adapters support. I would now like to check how this is currently configured on the USB adapter. Please follow the steps below:

  1. Right-click the Network icon in the system tray in the lower-right, and select “Open Network and Sharing Center”.

  2. Select “Change adapter settings” in the left column.

  3. Right click on the device named “ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter”, then select “Properties”.

  4. Click the “Configure” button.

  5. Select the Advanced tab.

  6. In the “Property list”, select “Speed & Duplex”.

  7. Please make a note of what the Value is currently set to. Depending on what it’s set to, please do one of the following:

  • a) If the value is set to anything other than “Auto Negotiation”: change it to “Auto Negotiation” then click OK.

  • b) If the value is already set to “Auto Negotiation”: change it to “1.0 Gbps Full Duplex” then click OK.

Please let me know what the Speed & Duplex value was set to prior to changing it, and if changing it made a difference.


#7

Ok the adapter was set on Auto Negotiate so I tried changing it to 1Gbps Full Duplex, but when I do that it won’t reconnect to the network and the network icon stays with a yellow exclamation mark on it. When I change it back to Auto Negotiate it reconnects to the network and I have internet again, but at the 100Mbps speeds.


#8

Any update to my last response?


#9

Hi Todd,

Thank you for trying that.

The results you’ve described confirm that the device connected to the other end of the Ethernet cable is set to auto-negotiate, but I’m still not sure why that device and the USB adapter are negotiating a 100 Mbps link speed. They should be negotiating the highest speed that they both support. If the other Ethernet port only supports 10/100 Mbps link speeds that would certainly explain the problem, but my understanding is that we already ruled out that possibility.

You had previously mentioned that other PCs with gigabit network adapters can access higher speeds when connected via the same network cable. During those tests, was the other end of the Ethernet cable connected to the same port on the switch / router?

If we are certain that the other Ethernet port supports gigabit link, and other devices are able to access speeds higher than 100 Mbps when connected to that same port, then I would like to check if there is an issue with the drivers installed for the USB Ethernet adapter. In that case, could you please run our diagnostic program? This will gather various logs from your system such as installed drivers and additional network status information. Please connect the USB Ethernet adapter to your computer and network, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Running this program should generate a ZIP file on your desktop. Please email that file to us directly at support@plugable.com, with “Ticket #195113” in the subject line.


#10