RS232 to USB Laptop Voltages


#1

We recently bought a Plugable RS232 to USB adapter for communicating with a RS232 instrument (PID controller). The problem we are having is that the adapter works fine and communicated well when we are using a desktop computer - but stops working when we switched over to a laptop (able to send commands, but not able to read). Drivers and settings on the two computers are exactly the same.

Now, I don’t think this is completely the problem with the Plugable adapter, because the instrument manufacturer admitted that the output (RxD) from their instrument is not the standard +/-12V. Rather, we observed that on the TxD pin, the voltage is between -5 and 0V, and on the RxD pin the voltage is between 0 and +5V. I believe 0V is not defined in the RS232 standard, so I am wondering how is this handled by the Plugable adapter?

I have two questions:

  • Why would the adapter work on the desktop but not on the laptop?
  • If you think the non-standard voltage might be a problem, do you see any easy way to correct/circumvent this?

Thanks in advance for your help.
Haynes


#2

Hi Haynes-

Thanks for posting here with a clear description of your findings and challenges!

I wanted to share some admittedly generic advice for initial troubleshooting since both the team members who might have a little more information are out of the office today.

I have a feeling this specific a question will need to go all the way back to Prolific, who makes the chip our USB serial adapter is built around. That said, I’ll be more than happy to cover some basic steps and review once the rest of the team is back Monday to see if we can come up with any further suggestions. While I know it isn’t relevant technically, I wanted to share another thread to let you know we do communicate these sorts of issues back to prolific to see if there is anything further we can do: http://support.plugable.com/plugable/…

So, for starters, it seems we know the USB-serial device works since it behaves normally with your desktop, and we’re really just trying to troubleshoot why the laptop can’t read when the desktop can.

After trying any basic steps things like eliminating any hubs or USB extension cables between the laptop and USB-Serial device, we’d also want to try different ports on the laptop. We’ve also seen cases where a long serial cable between the usb adapter and actual device have caused intermittent problems, so trying to go with the shortest cable run possible from device to adapter is preferred. Assuming none of that makes a difference, checking USB host controller drivers for available updates on laptop is about the last generic step I can recommend.

I’ll be very curious to hear if any of my generic steps help or if this is something we’ll need to look into a little deeper.

Again, thanks for posting, and have a great weekend!

Jeff Everett
MCITP Enterprise Support Tech
Plugable Technologies


#3

Hi Jeff,

Thank you for your quick reply, and the generic steps. I will add a little more details about what we’ve done.

We tried this on two separate laptops (an Asus, and a Lenovo), and both returned similar results. I am not sure if we tried different ports, so I’ll do that later today.

There are no USB hubs between the USB cable and the RS232 device.

For the cable, it’s a custom cable (DB9 - DB15) with the extra pins used for other purposes, e.g. DC power supplies. So it’s not a quick/easy test to make a new cable. However, the cable length is less than 1m, and we can see on an oscilloscope that the voltage at the other end is -5 -> 0V and 0-> 5 V as described above, so I am not sure if the problem lies in the cable length.

I have been keeping my laptop updated fairly often. But I will try to update the USB host cotroller driver later today as well.

Summary:
will try different USB port
will try updating host controller driver

I have a feeling that this might be a chipset problem as you suggest. So I am tempted to try an FTDI chip device. Will update you if we find anything new.

Thanks,
Haynes


#4

Hi Haynes-

Thanks again for providing those details, and please do let us know what you find or if you’ve any other questions.

We’ll be very curious to hear if you see any different results with a FTDI chip based adapter. If there is an issue with the Prolific chipset we’ll definitely want to raise that to their attention.

Best wishes-

Jeff


#5

Hello Jeff,

I have tried different USB ports on my computer and updating the host controller driver. Unfortunately, the results are the same. I am wondering if you’ve had a chance to consult with your other team members?

Thanks,
Haynes


#6

Hi Haynes-

Indeed, we have one quick fix idea- if you’ve got a powered usb hub, we’d like to see if connecting the serial adapter through the hub (so the serial adapter can draw power from the hub instead of laptop) changes anything.

Failing that, I’m not sure if we’ve any other workarounds, although there is some further Prolific documentation we can share to try and narrow down what the cause is.

I’ll be very curious to hear if you have a powered hub to try- please let me know if you don’t, and I think we’ll be able to work something out there :slight_smile:

As always, thanks for writing and best wishes-

JE


#7

Hi Jeff,

Thanks for the quick reply again!

I’ve had a quick survey around our office and I don’t think we have a powered hub. What do you mean we can work something out? :stuck_out_tongue:
Please contact me directly via email.

Much thanks,
Haynes


#8

Just for the record, in case anyone else is following this thread, I’m working with Haynes in a private channel to see if we can isolate the power issue.

Jeff Everett


#9