Raspberry Pi [RPi] doesn't see my Kb or mouse when attached via Plugable USB3 4-port hub


#1

My Kb & mouse [kb&m] work just fine when plugged directly into RPi, but neither are “seen” when plugged into your 81x4 hub. [Note: neither device is mentioned in the Verified Peripherals list [http://elinux.org/RPi_VerifiedPeriphe… ].

H/W: SIIG Mini Multimedia Kb 02-1230B (wired); MS Wheel Mouse Optical USB1.1; 16GB Sandisc U-1; 1Gb LAN; HDMI output. The hub used a micro-USB2 cable to power the RPi, and used a classic USB2 “A/B” up-link cable with what appeared to be a ferrite choke.

Otherwise, the hub seems Fine: RPi recognized a USB3 Seagate Backup Plus drive through the hub – I had to plug the mouse into the hub to free up the USB2 port for the hub, so the mouse disappeared in this connection; and the hub worked Beautifully when I attached it to my Win8 desktop computer’s USB3 port as I created the RPi SD drive and ran throughput tests.

Likewise, the kb&m work just fine off a hub when I replace your hub with an APC USB2HUB-7P-1V, ceteris paribus.

I’ve had both your hub and the RPi only one week: I haven’t learned enough of RPi-LINUX to diagnose this problem further. Note: I had no luck with a wireless kb&m connection to the RPi – which was just a brief test and may have some resolution – which left me with only my one set of -wired- kb&m… and the above problem. If I can unearth or borrow another kb&m, I’ll see if I have the same result.

Worst case: I’ve a great USB3 hub for my other computers. I’m quite impressed with the email exchanges I’ve had with Jeromy, the insightful posts I’ve read here, and the enthusiastic posts regarding Plugable I’ve read elsewhere.

Take care,


#2

Hi John-

Thanks for posting with your issue- I’ll be happy to help! I wanted to offer some quick input, and let you know that I’m sure Jerome will be happy to jump back in after the holiday tomorrow if I’m not able to get your questions answered.

1st things 1st, our top recommendation for a hub to work with (power and serve as a hub for) the Pi is the USB2-HUB-AG7:
http://plugable.com/products/usb2-hub…

In short, we would recommend you exchange the 4 port USB 3 hub for the 7 port USB 2 hub linked above. Below are some details on why.

1st, the 7 port USB2-HUB-AG7 is listed on the verified hardware list for the Pi:
“Plugable 7 Port High Speed USB Hub USB2-HUB-AG7 USB 2.0 7-Port 5V - 3A Verified [14] Better than usual power supply. There are US and UK power supply versions and it can be ordered in US and (for the UK version) many countries in Europe. There is a video showing this hub powering both the Raspberry Pi several peripherals at once[15]. No back-voltage on upstream connection. Widely used with success on the Pi.”

There are a few potential issues with USB 3.0 hubs- one of which is that wireless devices operating around 2.4 ghz are known to have issues on USB 3.0 ports. I know this sounds hard to believe, so don’t take our word for it, Intel published a rather comprehensive whitepaper on the topic, linked below. The best solution is to use USB 2.0 ports instead: cascading or daisy-chaining a 2.0 hub off a 3.0 hub may actually make sense here, especially if it lets you get the wireless devices physically further from the USB 3.0 ports:
http://www.intel.com/content/www/us/e…

Next, there is some potential that a firmware update for the hub might help, although at this stage that is just a guess. Details on checking the firmware version on the hub are here:
http://plugable.com/2013/01/29/via-us…

Lastly, just for public record, both these potential issue sources go into the “not verified” status on the pi for the USB3-HUB81x4 (incorrectly listed on the Pi hardware page as the USB2-HUB-81x4):
“Plugable 4 Port USB 3.0 Hub USB2-HUB-81X4 USB 3.0 4-Port 5V - 4A Not Verified The high-power 4 A power adapter makes this a tempting purchase, but some users report problems connecting devices with a USB 3.0 hub. Since Pi can’t benefit from USB 3.0, better off to use one of the Plugable USB 2.0 7 or 4 port hubs like USB2-HUB-AG7 to both power the Pi and attached USB devices.”

Hope this helps, but let me know of any other questions.

Best wishes-

Jeff Everett
Plugable Technologies


#3

I’ll struggle to keep this reply terse, but there’s a lot to mutter.

-1- I updated the Firmware, perhaps unnecessarily: the device driver now shows “VID 2109, PID 0811, REV 3198” indicating “firmware version 9.83”. [Either I was drunk, or the update-s/w should be reviewed and clarified by someone fluent in English.]

The same problems continued after the update.

-2- I worked out how to “connect/disconnect” Logitech Unified Keyboards & Mice under Linux [amusingly, the answer is “do it under Windows, then transfer the dongle to the Linux system”!] and switched to a Logitech K400 Kb+ScratchPad.

The same problems continued with the new Kb&M: they worked fine with the dongle in the RPi or APC hub, but not plugged into your 81x4.

Note: the above test, and the original tests, were performed in two modes… once with the 81x4 plugged into the RPi, once with it plugged into the APC hub… with no differences.

-3- “In short, we would recommend you exchange the 4 port USB 3 hub for the 7 port USB 2 hub…”

I was a bit disappointed to only read of the 7-port’s virtues, and nothing about -why- the 4-port has problems save the improbable theoretical 2.4GHz interference. My explanation for the problem is near the end, below.

I was aware of Plugable’s recommendation of the 7-port before I bought the 81x4, but my decision was based on several factors: size (I wanted -small-); power and power/port (both have the same P/S); cost; -positive- experiences posted regarding the 81x4; a willingness to “be wrong” and thus move the 81x4 to my windows systems :slight_smile: .

An “exchange” seems unlikely/difficult, and unnecessary given: the Unified dongle for the Kb&M leaves a RPi USB port free for -any- hub; the only devices I haven’t seen work are my Kb’s and Mice.

-4- The last clause, above, led me to move my identical Logitech Unified Device dongle on my Win8 system to the 81x4, re-mounted under Win8:

On the Win8 system, the dongle/Kb had NO problems, pretty much obliterating any 2.4GHz “issue” and making it apparent there’s a defect in the Linux driver for the VIA VL811 interface since it appears the VIA VL812 chipset (of the 7-port) works just fine.

And that about wraps it up. I hope this was as boring to read as to write! :slight_smile:

Thank you for your time…
John

PS: Apologies to Jerome for miss-naming him in the first post!


#4