Raspberry Pi 4 with Jack Audio Connection Kit

Hey, thanks for being what seems to be a very responsive forum judging from the activity here. I’ve got a Raspberry 4 and teh Plugable USB Audio Adapter. The audio output is working great, but the input I’m struggling with.

When I run aplay -l:
> **** List of PLAYBACK Hardware Devices ****

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 6/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Device [Plugable USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Like I said output works fine. But when I go to Jack Audio Connection Kit, no inputs show up


Just the guitarx stuff. I was expecting to see system > capture_1

Any ideas where to start? I’ve searched the forums here but most seem to be kinda old, about older versions of raspbian so I’m not sure if I should follow those instructions.

Thanks!

BTW Here’s the version of Raspbian I;m running:
PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian

And I can see it as an input when I right click on the audio in the toolbar.

It just doesn’t seem to work anywhere (Audacity, Jack Audio Connection Kit are teh two things I’ve tried)

I did notice I have a TS plug and NOT a TRS. Would that make it not even show up in Jack Audio though? I figured it would at least show up. In the meantime I’ve ordered an adapter that should be here tomorrow.

I tried running Plugdebug as found in another place in teh forum to no avail:

pi@raspberrypi:~/Downloads ./Plugdebug-Linux-i686-0.10.1.run Verifying archive integrity... All good. Uncompressing Plugdebug 0.10.1.............................................. ./Plugdebug-Linux-i686-0.10.1.run: 1: eval: ./Plugdebug: Exec format error pi@raspberrypi:~/Downloads ls
Plugdebug-Linux-i686-0.10.1.run Plugdebug-Linux-x86_64-0.11.1.run
pi@raspberrypi:~/Downloads $ ./Plugdebug-Linux-x86_64-0.11.1.run
Verifying archive integrity… All good.
Uncompressing Plugdebug 0.11.1 100%
./Plugdebug-Linux-x86_64-0.11.1.run: 1: eval: ./Plugdebug: Exec format error

Hello,

Thanks for reaching out to us! I am sorry for any trouble, and am here to help. With respect, I haven’t tried this GuitarX software out, (but this looks like a really cool project as a musician myself) and can’t guarantee compatibility. I have tested out Audacity with our Audio adapter, and can confirm that it does work for recording audio.

Are you converting from a 1/4 inch instrument cable, or XLR mic? Unfortunately, our adapter is only compatible with Tip Ring Sleeve (TRS) style jacks. Other jack styles unfortunately won’t work even if they are converted to 3.5mm jacks.

I look forward to hearing back from you soon!

Thank you,

Kevin
Product Owner
Plugable Support

THanks for putting up with me emailing AND posting here. Let me know where you prefer my replies, but in case anyone else is searching this and find this thread I’ll keep it here unless you say otherwise.

I noticed after my post and email abolut the microphone jack compatibility. Our 1/4" -> 1/8" adapter is just TS rather than TRS, so I’ve ordered a second adapter that will take that to TRS. I’m hopeful that will solve the problem. I’m just not sure if the lack of compatible jack would explain why the input fails to show up in the Jack Audio server that Guitarx uses :\ I’m hopeful this is it. I’ll follow up when the adapter is delivered and I try it out tomorrow

Sure thing! We always want to address concerns where they come in especially if others can see in forums or answers.

Again with respect, I want to mention that we’ve found that 1/4 instrument cables do not work with our adapter. Please let me know what happens!

Thank you,

Kevin
Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.