Problem with Plugable USB/Serial on Macbook Pro 10.11.5


#1

I just installed my new Plugable USB/Serial adapter onto my Macbook Pro running 10.11.5. Installation seems to have gone ok. I used the drivers from the plugable site (PL2303_1.6.0_20151012.pkg)

After a fresh reboot of my mac, I’m able to use the adapter to connect to a device’s serial port (a Cisco ASA firewall) using this command:
screen /dev/cu.usbserial 9600

Here’s an example of the processes that are running after using screen after a fresh reboot:
$ ps -ef | grep usbserial
501 1139 723 0 2:42PM ttys000 0:00.00 grep usbserial
501 1052 1031 0 2:42PM ttys001 0:00.01 screen /dev/cu.usbserial 9600
501 1053 1052 0 2:42PM cu.usbserial 0:00.04 SCREEN /dev/cu.usbserial 9600
$

But, then I close that screen window (by closing the iTerm2 window/tab or by issuing in the screen window CTRL-A then CTRL-\ and entering y).

Now, when I try to run screen again, the screen command returns nothing. And, the screen processes become hung. I cannot even kill those processes. I have to do a hard power-cycle of my mac. Which leads me back to square one.

Here’s an example of the processes that are running that I cannot kill:
$ ps -ef | grep usbserial
501 1460 1459 0 2:45PM ?? 0:26.89 SCREEN /dev/cu.usbserial 9600
501 1507 723 0 2:45PM ttys000 0:00.00 grep usbserial
501 1459 1433 0 2:45PM ttys002 0:00.01 screen /dev/cu.usbserial 9600

Can someone help?


#2

I just searched for a solution and found the info in the following link.

http://apple.stackexchange.com/questi…

I’ll try out the workaround when I get a chance.


#3

Hi WW,

Thank you very much for sending the link to a solution. Could you please post again about how it worked?

Thanks!

David Plugable Support


#4

Yes, this command worked for me (repeatedly).
sudo cu -l /dev/cu.usbserial -s 9600

I did not try the other suggestion from the above link (the one about doing “stty clocal < /dev/cu.usbserial”).

I have no idea where the fault lies when trying to use the screen command.


#5

Hi WW,

Thanks for the information. I’m going to close this thread. If you have any other comments or questions, please contact us directly at support@plugable.com. Thanks!

David


#6