Problem for new browsers: UGA-2K-A doesn't do hardware acceleration


#1

My UGA-2K-A DisplayLink adapter (running under Win7-64 bit, driver 5.5.29055.0, dated 11/26/2010) is apparently asserting that it supports hardware acceleration, but doesn’t actually.

This is a problem if I try to run the latest browsers (IE 9 beta, Firefox 4.0, Seamonkey 2.1 beta), which will attempt to use hardware acceleration if present. A window from one of those browsers, if displayed on my UGA-2K-A controlled monitor, will not update.

I have a workaround, which is to go into the browser settings and uncheck hardware acceleration. (Which can be tricky, as you might have to start the browser in safe mode, in order to do this.) It would be nice however if the DisplayLink adapter didn’t assert support for hardware acceleration in the first place, so that you wouldn’t have to do this.


#2

Hi Aaron,

Thanks for posting with this great information!

Can you try one quick thing. Can you run Windows’ Aero troubleshooter and see if it reports and fixes any issues?
Here’s how: http://windows.microsoft.com/en-US/wi…

And if it does, can you try re-enabling acceleration?

Bernie


#3

Thanks for the suggestion. I personally keep Aero off (can’t stand it.) I ran the Aero troubleshooter - the only thing that it complained about and “fixed” was to enable the Desktop Window Manager and thereby Aero.

Interestingly, by enabling Aero - this *did* seem to fix the problem! So I guess I’ll have to pick my poison - either turn on Aero or turn off hardware acceleration.


#4

Hi Aaron,

Great! By the way, here’s some background on why this is the case:

“Aero” isn’t just a visual effect, it’s actually a completely different rendering path for graphics in Windows (desktop composition instead of traditional).

* Higher-level apps (traditional GDI apps), are shielded from knowing the difference, but apps which use advanced features (DirectX or WPF) are very much affected, depending whether desktop composition is enabled or not.
* Within graphics drivers, the shift from XPDM to WDDM drove graphics drivers to commit to the desktop composition model.
* “Virtual” graphics drivers like DIsplayLInk’s running over USB need to hook into the graphics stack to do their work, and the only single place where all rendering can get caught in Vista/7 is at the aero/desktop composition layer. For Basic mode, individual higher level operations need emulated.

So WIndows has unfortunately set up the situation where low-level software, and more and more high-level software is dependent on which rendering path is in use (Aero/Basic). And unfortunately, that’s very easy to disable/switch (either the end user, or any software on the system that wants to).

So it makes the behavior of apps that are using advanced features somewhat fragile. Fortunately, Aero is easy to re-enable (the troubleshooter they have).

Hope that background helps. And in any case, glad to have you up and running!


#5

I have been experiencing the same problem. Did everything explained above and the problem is still there. Windows 7 64bit, Firefox 8.0.1 and IE 9. However, turning off “hardware acceleration” DOES work…


#6

Hi Guang. You may be running into something different. If you could generate DisplayLink logs (here’s how: http://plugable.com/support/tools/dis… ) and email to support@plugable.com, we should be able to see what’s different about your machine and get you fixed up. Thanks!


#7

Hi Bernie,

Thanks for your prompt reply. I spent hours yesterday to figure out why the plugable adapter would not work in vein until I disabled the hardware acceleration. I even switched back and forth to make sure that was either the problem or at least a solution. But today when I was trying to duplicate the problem for the DisplayLink log, everything was working! Not sure why. I switched on and off the hardware acceleration and rebooted the computer a couple of times. And, it is still working. Hopefully this is it. Thanks again.


#8

Using the Windows Aero troubleshooter fixed the problem for me. I have a Lenovo T410 Thinkpad with Win7 Professional x64. Adobe Flash and other fullscreen videos were not working on my extra monitor connected to a UGA-2K-A running at 2048x1152. Now it works!


#9