Problem connecting 4 monitors on Surface Pro with RDP to remote server


#1

I am able to run 4 additional monitors with the UD-3900 docking station on my Surface Pro just fine. When I try to log in to my remote server, only one monitor shows the server desktop. Before I got the Surface, I was able to run 4 monitors with RDP with no problems. How can I get this to work?

Jim


#2

Hi Jim,

Thank you for posting!

Thank you as well for the detail you provided that is much appreciated. A quick note up front, our dock cannot control the behavior of the Microsoft Remote Desktop application on its own.

Further to this, support for multiple monitors within the Microsoft Remote Desktop Client can be tricky due to specific requirements both on the host and server. Adding to the confusion is that Microsoft doesn’t have great documentation in this area. We will of course do our best to help, however we want to set honest expectations up front that we may not be able to provide a solution.

That said, our next step is to get some additional information. First, can you confirm which version of the Microsoft RDP application you are using? I ask because Microsoft has two versions available for Windows 10, an older version called ‘Remote Desktop Connection’ and a newer version in the Microsoft Store called simply ‘Remote Desktop’ (I have attached example screenshots of each to this post to help you identify which is which).

I ask because the older version of the application can support multiple local displays, however to the best of our knowledge the newer version does not (it only supports a single local display).

Thank you,

Bob
Plugable Technologies

Old version of client:

001_OLD_Remote_Desktop_Connection

New version of client:


#3

I am using the older version. I could not get the newer one to connect to the server anyway.


#4

Hi Jim,

Thank you for getting back with the update.

Given you are using the older version of the Microsoft software, there is only one relevant setting to check within the RDP application:

  1. Open the ‘Remote Desktop Connection’ application, and if not already expanded click on the ‘Show Options’ drop-down arrow.

  2. From the expanded window that appears, click on the ‘Display’ tab at the top.

  3. Under the ‘Display configuration’ section, ensure that there is a check mark present in the ‘Use all my monitors for the remote session’ option (example attached below).

  4. Attempt to connect to the server again.

Please let us know if that helps!

Bob

003_use_all_monitors


#5

Yes, I have had the Use all my monitors checked from the beginning.


#6

Hi Jim,

Thanks for getting back with the confirmation regarding the Remote Desktop Application settings.

Given our dock cannot control the behavior of the Microsoft RDP application as mentioned previous, I am unable to explain the current behavior and as a result I am afraid we are running out of troubleshooting options.

I presume you are running Windows 10 on your Surface…is it possible for you to share the operating system version of the remote server to which you are connecting? I ask because the different versions of Windows have different capabilities in terms of their support for multiple displays over RDP, and this information may help determine the cause.

Thank you,

Bob


#7

We are using Server 2012 R2. Yes the Surface in Win 10.


#8

Hi Jim,

Thank you for getting back with the additional information, and apologies for the delay in my reply (I wanted to do some more research on the subject).

It appears that Windows Server 2012 supports multiple displays via RDP, and in most cases simply setting the “Use all my monitors for the remote session” option allows multiple displays on the local host remotely connecting to a Windows Server 2012 system to work as expected. However, I am again unable to explain the current behavior given you have confirmed this option is enabled locally.

A Google search indicates that many others have reported similar problems across a wide variety of situations and platforms (most of those without our product in use), however there does not appear to be a definitive ‘catch-all’ solution.

Digging deeper into the Microsoft support forum for the Remote Desktop Client (https://social.technet.microsoft.com/forums/windowsserver/en-us/home?forum=winrdc) and for Remote Desktop Services (https://social.technet.microsoft.com/Forums/windowsserver/en-us/home?forum=winserverTS), and reviewing the various documentation that Microsoft provides ( https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/troubleshoot-remote-desktop-connections & https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/remote-desktop-client-faq & https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/remote-desktop-app-compare ) unfortunately did not provide any obvious solutions either.

As a result, I am afraid we do not have a solution to offer other than checking that the relevant Remote Desktop Services settings within the server are configured to allow for the use of multiple displays on all remote clients.

Apologies that we cannot be of more help in this specific case…

Bob


#9

Thanks for your time in researching this. I will keep working on it from my end.