Power issues with PANBT400 Bluetooth dongle? Inrush current?


#1

I’m trying to use your Bluetooth dongle with a TI AM335x processor (like the Beaglebone, only not) running Linux. If I plug the dongle in after boot, everything’s fine. If I plug it in before boot, many (not all) times, the processor disables power to ALL the ports on the same USB hub as the dongle. Yes, it may be an AM335x or hub problem (although the hub is powered), but I’ve tried all their solutions with no joy, and it only appears to happen with this part. USB memory sticks, WiFi adapters, and many other devices don’t seem to trigger the same problem. So guess who gets the blame :wink: If I hardwire the USB port (with the dongle) to 5V, no problem.

I’ve tried more than one, so it’s not just a bad dongle.


#2

Thanks for posting.

We have never tested the adapter with a TI AM335x processor, so I can’t speak to exactly what is happening there, but I’ve been supporting this problem for nearly four years, and haven’t seen this on any other systems, including the Raspberry Pi. I use the adapter with hubs all the time without troubles.

If your contact us directly on support@plugable.com, I can arrange a return and refund for the adapter.

Thank you,

David
Plugable Support


#3

I’m going to close this thread. If you have any further questions, please contact us directly at support@plugable.com. Thanks


#4