Port not working on USB Hub


#1

Got a Plugable USB3-HUB7-81X Seven-Port USB 3.0 Hub with Four-Amp Power Adapter for Christmas (which I love), but am having problems with the 7th port - indicator light flickers rather than steady on & device is not usable.


#2

Hello,

Thanks for posting your question here. I’ll be able to assist. The first thing to check is if the port works with a simple USB device like a wired USB mouse. If it has the same issue we’ll suspect that port is failing.

If the mouse works let me know and we’ll figure out the best next steps to isolate what could be wrong. If it doesn’t work, just forward your Amazon Order Id over to us at support@plugable.com and we’ll get you fixed up.

Thanks,
Jerome.

Plugable Technologies


#3

I actually noticed this yesterday with my USB 3.0 Hub with 4A adapter. I have three HDDs (1 - 3.0, 2 - 2.0) and tried to connect my 4G Motorola Droid Bionic to port 4 and the light was flickering and kept popping up the drives on my computer and then ejecting them right away. So I tried another cord and it worked flawlessly. I then connected another device that uses somewhat a lot of power to port 5, which is my RCA video capture device, and tested that with the other 4 devices attached and no problems. So I suspected it just had to be the quality of the cord that was/is the issue with certain devices. Try changing the cord to one of better quality.

-Don :slight_smile:


#4

Thanks, Don. I tried using the same device on all ports (it was a usb mouse.) It worked on all but the last port, so I am thinking that my problem must be related to the hub. Does that sound right to you?


#5

Hi Barbara,

Your symptom of having one port that doesn’t work with a USB mouse does sound like a problem with your hub. We sent you some information directly on how we’ll get your issue fixed.

Let us know how it goes!

Thanks,
Jerome.


#6