Pluggable USB-C 4K Display Port not working

Display port on 3rd screen not working. Switched monitors to confirm it was an issue with the port

Following. I’m also experiencing a the 4k port not working. I used the DVI in this pinch but I’d prefer the 4k over that for sure. Any trouble shooting tips would be appreciated.

Hello!

Thanks for contacting us. Sorry to hear about this issue.

@nickslaught38 can you tell me which physical port you’re referring to on your UD-ULTC4K dock? Is it the HDMI port or one of the two DP ports? If DP, is it the top or bottom?

Was this port working before? Or is has never worked?

@santiagazo it sounds like you have our UD-ULTCDL which is a different model than what the original poster has. I recommend to start a separate thread about your issue or to contact us directly at support@plugable.com for further assistance.

In addition, not all systems with USB-C can support the HDMI port on the dock. This port requires the system to support USB-C VESA DisplayPort Alternate Mode video output which is an optional feature for USB-C. Another possibility is if you’re not using the USB-C cable that shipped with the dock. Not all C cables can support the aforementioned Alt Mode signal, so be sure to use the original cable.

Thanks and best wishes!
Joshua Henry
Plugable Technologies

Joshua,

Both Display ports are currently not working. It was working for a short hour today and suddenly stopped. I have tried switching out cords to see if it was an issue with the cord but it is not.

Thanks for the information. If both DisplayPorts aren’t working, it may be driver related. The two DP ports, Ethernet, and audio in this docking station are all driven by the DisplayLink USB graphics chipset in the dock.

We can try proactively performing a clean install with the latest drivers and see if that helps. Here’s how:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step.

  3. Download, extract and run the DisplayLink cleaner tool, found here --> http://www.displaylink.com/downloads/file?d=64 and ensure it displays “Cleaning Complete”
    when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 9.4 DisplayLink software, found here --> https://www.displaylink.com/downloads/file?id=1623

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

If this doesn’t help, we should try and collect some diagnostics for your system. We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Thanks!
Josh

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.