Pluggable UD-3000 Drivers not Installing Correctly on Windows 7 Pro


#1

Drivers will not install correctly on Windows 7 Pro for a UD-3000. Tried the latest driver off of the support website.

Appears to be similiar to the Topic name, “Lenovo Windows 7 Does not find drivers for USB 2.0 Hub (MTT)”

How can we get the pluggable device to install correctly when connected to the laptop via usb?

Thanks for your help.


#2

Hi Josh,

Thank you for posting here, we’d be glad to help! Here are the steps to install DisplayLink’s latest driver v7.2 M1:

  1. Disconnect the dock from the machine and run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  2. Download v7.2 M1 from the below link and follow the installation prompts.

http://www.displaylink.com/support/sl…

  1. Reboot the computer and reconnect the dock, it will take up to several minutes for the drivers to re-enumerate

Try connecting to your monitor/devices again at this point and see if the behavior is any different. Let me know how it goes!

Thanks,
Ellen


#3

We tried the above solution and still get the same error.

What else can we try? (with a Windows 7 laptop, multiple displays, and mouse/keyboard)


#4

Hi Josh,

It would be very helpful if you could capture and send us the DisplayLink log file, it gives us detailed information on how your system is setup and helps us narrow down the problem. Step by step instructions on how to collect this log file can be found here:

http://plugable.com/support/tools/dis…

Please send the file to support@plugable.com along with a link to this thread and we’ll take a look!

Thanks,
Ellen


#5

The device is plugged directly into the laptop. I hadn’t tried to plug it into a USB 2.0 port but once I did it started working again. How can we fix the USB 3.0 issue. Thanks


#6

Great, now that we’ve narrowed down the problem to a USB 3 host controller issue, we can look for ways to get around that. I looked on Toshiba’s siite for this laptop model and didn’t see any updated USB 3 host controller drivers offered, but there are quite a few BIOS updates for this system. Let’s start by updating to the latest BIOS v6.60, currently v6.30 is installed. Here’s the link from Toshiba:

http://support.toshiba.com/support/mo…

Disconnect the dock prior to the update and reconnect the dock after reboot. Let me know what you see!

Thanks,
Ellen


#7