Plugable USB2-E1000 stopped working after Apple firmware update


#1

I have the Plugable USB2-E1000 (ASIX AX88178). Today, it stopped working. No flashing lights, nothing. First, I thought I just have to reinstall the driver, as I did an update yesterday of the Apple firmware (the update was to support Ethernet Gigabit over Thunderbolt). Any ideas?

I am on OS X Lion 10.7.4 (Macbook Air mid-2011).


#2

I have also tried moving (and unloading) the ‘AppleUSBEthernet.kext’ to /asix_temp, as it was still there after the installation and got loaded when I inserted the adapter. This should not happen right?

This is what is loaded after I plugin the adapter with the cable (I can also add the interface in the Network settings).

sudo kextstat | grep AppleUSB
31 0 0xffffff7f80a53000 0x10000 0x10000 com.apple.driver.AppleUSBUHCI (4.4.5)
32 0 0xffffff7f80a96000 0x17000 0x17000 com.apple.driver.AppleUSBEHCI (4.5.8)
41 0 0xffffff7f80a81000 0x11000 0x11000 com.apple.driver.AppleUSBHub (4.5.0)
54 1 0xffffff7f80a47000 0x6000 0x6000 com.apple.driver.AppleUSBComposite (4.5.8)
55 0 0xffffff7f80a7b000 0x6000 0x6000 com.apple.driver.AppleUSBMergeNub (4.5.3)
57 0 0xffffff7f8152a000 0x4000 0x4000 com.apple.driver.AppleUSBCardReader (3.0.1)
59 0 0xffffff7f8145b000 0x4000 0x4000 com.apple.driver.AppleUSBTCKeyboard (225.2)
60 0 0xffffff7f81458000 0x2000 0x2000 com.apple.driver.AppleUSBTCKeyEventDriver (225.2)
61 0 0xffffff7f81464000 0x13000 0x13000 com.apple.driver.AppleUSBMultitouch (227.1)
63 0 0xffffff7f81460000 0x3000 0x3000 com.apple.driver.AppleUSBTCButtons (225.2)
69 1 0xffffff7f80d6d000 0xb000 0xb000 com.apple.driver.AppleUSBBluetoothHCIController (4.0.5f11)
139 0 0xffffff7f8173f000 0x9000 0x9000 com.apple.driver.AppleUSBGigEthernet (3.6.0)

It keeps saying for the ‘USB Gigabit Ethernet’ interface that it is “not connected”. Does this mean that the adapter is broken? I just had it for 2 days and it was working perfectly fine.


#3

Hi Damir,

Hello from Plugable support. I’m sorry about the problems with the Gigabit adapter. Before we get into looking at which kext is loading or not loading, let me ask one quick troubleshooting question. Do you have the Android File Transfer utility app installed on your computer? This app has been proven to interfere with both this USB Gigabit Ethernet adapter and Apple’s own adapter. If you do have the Android app, can you remove it, reboot, and let me know what happens?

We’ve had some customers who didn’t even install the app themselves but got it with a package of software for connecting their phones to their Macs, so you might need to look a bit for it in your Applications.

Let me know if you did have it and whether removing it made a difference. If either removing it made no difference or you didn’t have it, we’ll continue down the support process.

Again, sorry for the hassle of a product that isn’t currently working. I’ll do my best to get you up and running with it again. Just reply to continue the conversation.

Best Regards,

Aaron
Plugable Technologies


#4

Hi,

I already had a problem with the Android File Transfer utility for my regular Apple USB ethernet. I removed it already quite some time ago. And besides, my regular Apple USB works now, so probably it is not the Android File Transfer utility.

Thank you in advance.

Damir


#5

Hi Damir,

Thanks for the confirmation. I will get in touch with you via our private ticketing system to continue the support process. Please look for a new e-mail thread from support@plugable.com with next steps.

Best Regards,

Aaron
Plugable Technologies


#6