Plugable USB2 Dual Monitor USB Dock, In Conjunction With Plugable A/B Switch Issue.

Hi folks,
I’m running a Windows 7 desktop and a Windows 10 laptop through the A/B switch and then into the docking station. LAN, wired keyboard, wireless mouse, USB printer and 2 monitors are connected to the dock.

For the first couple of weeks, the above setup worked flawlessly. I simply hit the A/B switch to toggle whether the laptop or desktop would be used and displayed via the monitors.
A problem then arose, happened occasionally, but then became permanent:

  1. If i’m switched to the laptop, the mouse wakes the displays up no problem.
  2. However, if i’m switched to the desktop, nothing happens. It all stays dead and the monitors remain asleep.

I tried using a mouse connected to the desktop, wouldn’t wake up.
I tried switching the ports around on the A/B switch, but the same problem remained with the desktop not waking up the monitors.

I gave up for 4 months and used the laptop only (busy job, so I had to put the computer issue aside).
Randomly a few days ago I noticed a glow in my dark office, and lo and behold the monitors were ON and displaying the desktop PC!
I quickly grabbed the opportunity to jump into the desktop’s own settings to make sure that it wasn’t a sleep setting that was causing the issue, and I saw nothing obvious. I have it set so that the monitors and hard drive never turn off.

All worked well until 2 days later, and I was using the desktop and the cursor stopped moving when I was moving the mouse. I used the A/B switch to move over to the laptop (which was working correctly), waited a minute or so, and then switched back to desktop. I clicked the mouse and the monitors fired up fine and the mouse was working again.
That lasted for an hour, and then the cursor stopped moving again, but this time switching from desktop to laptop and then back did NOT fix it.
That’s still the case; if I click the mouse while the A/B switch is for the laptop, all is good and the monitors wake up. If I switch to desktop and click the mouse though…nothing.

That’s the scoop folks, but i’m certain that i’m missing some info that you may need. So please fire away!
Thank you to anyone who can help me with this, as it was such a great setup for me when it was working.
Dave J.

Thanks for getting in touch!

This sounds like a power configuration issue on the Windows 7 machine. Could you contact me at and mention ticket #224382 in reference to this issue? I’d like to gather logs and take a look.

We haven’t heard back from you, so I’m hoping you were able to resolve the issue. If that isn’t the case, please contact us at for assistance!