Plugable USB Video Graphics Adapter not working with Displaylink dock

I have a Displaylink Bestthing USB 3.0 dual video docking station and also have a Plugable UGA-300 USB video graphics adapter that has allowed me to have a third monitor. This morning, my driver updating system updated the Displaylink driver to the newest version and afterward, the USB graphics adapter did not work (blue power light is on for a few seconds, then goes off).

I have tried the following:

  1. Plugging the USB video graphics adapter directly into a USB port on my laptop
  2. Followed your instructions for removing the Displaylink software, cleaning and then re-installing – when I did this, the software updated just said that the Displaylink software was the latest version

My docking station, with the two monitors is currently working fine, but the USB adapter still doesn’t work. Any assistance would be greatly appreciated. I really need the third monitor.

Since you’ve already performed a clean install, we’ll need to grab logs from your system to determine what might be going on here. Can you run our log gathering tool, Plugdebug, and send us the resulting .zip archive? Here’s how:

I’ve opened ticket #326183 for this case. Please send an email to with Ticket #326183 in the subject line so that gets assigned to me directly!

After log analysis, I suspected that this UGA-3000 was defective, and we replaced the unit under warranty. I’m happy to report that @nandes received the replacement yesterday and the issue is now resolved!