Plugable USB to gigabit ethernet driver needs to be reinstalled every reboot


#1

I recently acquired the USB to gigabit Ethernet adapter to upgrade the speed of a laptop I’m using as a server (I’m using a Mini9 with OSX 10.6.3 installed)

I followed the instructions, went to the web site and installed the most recent driver. Everything works fine, but every time I reboot the system the network preference panel reports that the adapter has a self-assigned IP. The only way to get it working again is to perform a full uninstall/reinstall cycle.

Any thoughts?

Thanks,
Rob


#2

Hi Rob,

Thanks for posting, and sorry you’re seeing a problem here!

Apple broke many USB network adapters with the Mac OS X 10.6.2 update, and for a while all ASIX based devices had this problem (only self-assigned IP) on every reboot.

But then ASIX released an updated driver which appeared to solve the issue.

But from the symptoms, it definitely sounds like you’re hitting a similar issue, so let’s try to figure out what might be happening.

Could you do a fresh re-install of the driver (so that it’s working), then open a command prompt or terminal, and run the two commands

kextstat | grep “AX”
kextstat | grep “Ethernet”

Making sure to get the capitalization all right. Can you say which of the two commands returns a result, and what it is?

We’re checking here to see which of the Apple or ASIX ethernet drivers are running – as the first suspicion to run down is that the Apple driver (rather than the ASIX driver) is still getting loaded.

Thanks for gathering this info as a first step, so we can figure out how to approach this. Thanks for your patience!
Bernie


#3

Hi Bernie, thanks for your prompt response!

I have performed a fresh driver install and run the commands you specified:

kextstat | grep “AX” returned nothing
kextstat | grep “Ethernet” returned:
88 0 0x327d9000 0x6000 0x5000 com.apple.driver.AppleRTL8169Ethernet (1.1)
114 0 0x34323000 0x9000 0x8000 com.apple.driver.AppleUSBGigEthernet (3.3.0)

Thanks for your assistance.
Rob


#4

Hi Rob,

OK, great - that’s it. It appears that the ASIX drivers did not successfully install (if it had, you would have seen an “AX88178” driver there, rather than “AppleUSBGigEthernet”). Your machine appears to have been running Apple’s built-in Gigabit Ethernet driver, which does have the symptoms you’re describing on any non-Apple branded AX88178 devices.

So we need figure out why the ASIX-provided AX88178 driver was not successfully installed.

The one case where I’ve seen this install problem before is when a 3rd party .zip utility was used to unzip the ASIX driver package, rather than Mac’s built-in folder utility (see http://support.plugable.com/plugable/… for the history)

What was happening is the 3rd party .zip utility was stripping permissions from the install scripts, which caused them not to run.

Is there any chance you used a 3rd party tool to unzip the ASIX driver package? If so, could you try opening the .zip just from the finder?

Thanks for trying that and letting us know - if there’s any trouble we’ll figure out next steps.

Thanks!
Bernie


#5

I’ve just been using the default “Archive Utility,” (the one with the green zipper icon).

Using the recommendation from the thread you linked to in your post, I tried chmod 777 on the installer at every stage of decompression, did a fresh uninstall/reinstall loop, but it looks like the Apple driver is still being used:

kextstat | grep “Ethernet”
86 0 0x327e5000 0x6000 0x5000 com.apple.driver.AppleRTL8169Ethernet (1.1)
114 0 0x3444f000 0x9000 0x8000 com.apple.driver.AppleUSBGigEthernet (3.3.0)

Any other ideas? Thank you for your continued assistance.
Rob


#6

Hi Rob,

It sounds like the zip part of the process is fine, but something else is causing the driver install to fail. We’ll track that down what possibilities might be and get back with next steps.

Two things to double-check while we’re doing that

  1. ASIX’s Mac OS X drivers are 32-bit only … check if you might be running 64-bit: http://support.apple.com/kb/HT4287
  2. Check that you’re using a user account with Administrator privileges (required to install drivers).

Probably both fine, but it’s two more places where things can go wrong.

Thanks for your patience!
Bernie


#7

Hi Bernie,

I double checked: I am using an administrator account and the 32-bit kernel.


#8

Hi Rob - Just a quick update that we’re still looking for the key to what might be different here … there still appears to be an ASIXdriver install problem, yet we’re not seeing this on any other similar Mac configurations.

Please just let us know if the clock is running down for you (either your 30 days since order, or your patience in answering our questions). A refund will be no problem.

But we’d like to get this figured out and get it working. Thanks for your patience!
Bernie


#9

Hi Rob,

A few updates and thoughts:

After looking around a bit, OS X 10.6.3 being a few versions back could affect things – apple was making changes (and breaking) some things related to USB ethernet in .2 -> .4. Here’s some potentially similar issues: http://www.motherboardpoint.com/mac-m…

It’s not a certain solution, but we’re not able to reproduce the problems on 10.6.7, is it possible on this system to upgrade to the latest 10.6.7?

Also, since posting I realized that ASIX has updated their AX88178 Mac ethernet drivers, with apparently 2 major changes

  1. Moved from distributing as .zip file to .dmg file (http://support.plugable.com/plugable/…)
  2. Switched back to using Apple’s kext name (AppleUSBGigEthernet) rather than AX88178. So the test we did above to check which driver was in use is probably reporting AppleUSBGigEthernet because you got the newer driver package.

If in doubt, I’d recommend re-downloading and reinstalling the package again: http://www.asix.com.tw/download.php?s…

Lastly, the problems introduced in OS X 10.6.2 (http://www.insanelymac.com/forum/inde…) caused DHCP/auto-IP address assignment to fail like you’re seeing.

A workaround is to manually assign a fixed IP address to the adapter. If all else above fails, have you already tried assigning a fixed IP address? http://portforward.com/networking/sta…

Let us know how things go. Thanks for your patience!
Bernie


#10

Hi Bernie,

Well I tried updating the operating system to 10.6.7. Unfortunately the mini9 couldn’t take it and it resulted in kernel panics on boot.

No big loss, I decided to roll back to 10.6.0, restored from time machine backup, and reinstalled the drivers. Surprisingly, I’m experiencing the same problem on reboot, in 10.6.0! Do you think this could be related to restoring the time machine backup?

I tried a self-assigned IP, but even though the little light in sys pref turned green, it could not access the network.

We certainly gave this the old college try, but I’m starting to think my hardware is just incompatible. Any other thoughts?

Thanks for your continued assistance, you have great customer service at plugable!


#11