Plugable USB Serial Adapter Installation Error Windows Vista Home Premium


#1

I have tried to install this device on my Windows Vista Home Premium PC
I downloaded the latest drivers from the plugable website

When I plug it in, Windows starts installing the drivers, but reports an error message.

I uninstalled the device, rebooted, but get the same result.

Please help


#2

Hello Ben,

Thanks for reaching out and posting on our forums. I apologize for the issue you’re experiencing, we would be happy to assist you with that driver problem you’re having. In order to best assist you, I believe it’d be best to work over email on this one. I’d like to gather some log files from your computer so we can better understand where the issue may be coming from. Could you please do the following and send an email to support@plugable.com?

  • Connect the device and please run our debug tool (here’s how: http://plugable.com/support/plugdebug).
  • In your email to us with the .zip from the debug logs, please include your Order ID, we will need this if we end up exploring warranty options.
  • Take a screenshot or describe the error you’re receiving when connecting the Plugable device.

Once I have this information, I should have a good idea of what we can do to try and resolve this driver problem. Please email the info, logs, and screenshot to support@plugable.com and I’ll be on the lookout for it! From there, we’ll continue things over email if that’s alright with you (rather than here on the forums).

Let me know if there’s any questions, and I look forward to working with you on resolving this!

Regards,

Patrick
Plugable Technologies
www.plugable.com/support


#3

Hi Ben,

As a heads up, we’ll be closing this thread. That said, if you still need assistance with the drivers please send an email to support@plugable.com and we would be happy to assist you!

Regards,

Patrick


#4