Plugable USB-C Triple Display Docking Station Slow Download Speed with HP Spectre X360

I’ve got the Plugable USB-C Triple Display Docking Station connected to an HP Spectre X360 with an Ethernet cable plugged into the docking station. Comcast is my ISP and I have the 400 Mbps service. When I’m connected to the docking station, my download speed on is 94 Mbps. When I disconnect the docking station and run the test using WiFi, the download speed is 382 Mbps. I get similar speeds on my phone which is connected to the same WiFi as the laptop. I like the flexibility of the docking station so I’m really hoping there’s a driver fix for this.

Hello Mike,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Do you know if your Internet modem and/or router (or combination Internet gateway) from Comcast supports greater than 100Mbps over the wired connection? Since you’re maxing out at 94Mbps it seems like your network connection to the dock may only be operating at 10/100 speeds. We’ve seen many times where WiFi may support say wireless AC1200 speeds (or similar, just using that as an example) but where the wired connection out for the local network is just 10/100 and not 10/100/1000 which would be required to see greater than 100Mbps speeds.

It’s also possible that the Ethernet cable isn’t wired to support higher speeds, but that’s super rare to see a non-standard CAT5/CAT6 cable.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies |

I’ve got a Netgear Orbi RBR50 router and a Netgear CM-1000 high speed cable modem. Both are capable of 1Gbps speeds. Your suggestion did make me realize that I’m using a Netgear Fast Ethernet Switch that’s only 100Mbps. So, I connected the cable from the router directly to the docking station. My download speed did go up to ~130Mbps but that’s still far from the WiFi only (NO dock connected) speed of 382Mbps. One more test - NO Ethernet cable plugged into the dock but dock plugged into computer yielded only 170Mbps download speed. So, the docking station is somehow slowing my WiFi connection. How can this be and should I ditch the docking station all together?

Hi Mike,

Thanks for the info. Very strange that the max you’re able to get is ~130. Still far less than we would expect.

For the WiFi situation, we actually have a blog post about that here:

The short of it is that USB 3.0/3.1/Type-C devices can emit 2.4Ghz interference which can degrade WiFi performance. Switching the WiFi over to a 5Ghz band would likely resolve this. While not all routers offer 5Ghz as a band option pretty much any modern wireless N or AC router should.

Also putting some distance between dock and laptop can help, though there’s not a lot of room to work with given the limitations of length for USB-C/Thunderbolt 3 cables.

If you end up needing to return the dock due to the interference issues just let me know. If purchased from us on Amazon I can issue you a prepaid return shipping label and a full refund.


Thanks for the blog link, there was some good info there. The Orbi has both 2.4GHz and 5GHz bands and it rather than being allowed to manually assign an SSID for a specific band, the Orbi router uses a technique that allows the connecting device to use the “best” option. I clicked on the properties link of my WiFi connection and it is connected to a 5GHz band. I changed the 5GHz channel from 48 to 44 based on info from the blog and achieved a download speed of 406 Mbps. That was a good tip to try changing the channel.

So, the solution is to NOT use the Ethernet port on the docking station and just go with WiFi. I like everything else about the docking station AND the support is so darn good so I’m keeping it.

Thanks for all your help,


1 Like

Hi Mike,

Glad to see that helped the WiFi speeds, and I agree in this situation using WiFi sounds like the best option. Should you ever need anything else please do let us know, we’re always happy to help!

Best wishes!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.