Plugable USB C Triple display docking station doesn't detect third monitor after reboot

Folks, I recently bought this triple display docking station. It only display me all my three monitors when I do the clean install of the display link driver.

Every reboot causes my laptop to keep fluctuating and never detects my third monitor. I am using all three monitors from the same vendor prism+ w240.

It’s really frustrating to do a clean install after reboot. Can you please suggest whether there is any solution to this?

Thanks!
Nitesh

Hi,

Thanks for contacting us! I am sorry this is not working as expected.

Every reboot causes my laptop to keep fluctuating and never detect my third monitor.

Please let me know which port on the docking station is connected to this third monitor, for example the “HDMI 1 Alt-Mode” port, or one of the HDMI 2 or HDMI 3 DisplayLink ports.

Based on your description of the behavior, our first step is to get some additional information from your system to check for incompatible drivers or out of date software that may be affecting the docking station’s display connection.

If you would, please keep the dock connected to the computer with monitor(s) connected tot he docking station (even though one may not be working) and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to ‘support@plugable.com’ with the subject line ‘Ticket #345393 - Attention Pat’ as this will allow us to examine some log files from your system to help determine the next steps.

Thanks,

Pat
Plugable Technology
support@plugable.com

Hi,

Thank you for suggesting the solution!

It actually somewhat has workaround the issue. Now, first I need to get my laptop working with two monitors, then later once they are working, turn my third monitor on.

Anything can you suggest for it?

Also - what do you suggest whether keep the docking station turned off while not in use? some articles suggest keeping it off so wondering what do you suggest?

Thanks,
Nitesh

Hi I think I am facing the same issue after a windows update. I have tried the clean install and rebooting as well and I am unable to detect my HDMI port. The issue does not appear in my work laptop without the windows update and I am able to use the monitors properly

Hi Nitesh,

Thank you for replying back, just to confirm I understand your workaround, are you turning off the monitor by pressing the power button on the monitor itself before turning off the computer, then turning the monitor back on ( again pressing the power button ) after loading into the operating system?

Please let me know which HDMI port on the docking station this display is connected to. Would it be possible to swap this display with one of the other displays on the docking station to see if the issue affects the same display, or any display connected to the same output port?

Thank you,

Hi Kat_j,

Thank you for contacting us, I am sorry this is not working as expected after the Windows update. This could be the result of a failure to properly update a graphics driver. I recommend starting by checking for any pending updates, the fully resetting the docking station:

  1. Open the Start Menu > Settings (cog icon)
  2. Select “Update & Security”
  3. Press the “Check for updates” button
  4. Please apply any pending updates, and if available, any hardware/driver updates ( there may be a separate link below the “Check for updates” button if drivers are available.
  5. Restart the computer when completed

Please let me know if this helps to restore the docking station’s HDMI output.

Pat
Plugable
support@plugable.com

Hi Pat,

I have updated windows and all dell drivers available but the problem still persists. I have submitted my log files to a colleague and he will be looking into this.

Kat_j

Hi Kat_j,

I wanted to check back in to see if you had found anything after submitting your log files to a colleague?

If the issue is not resolved, our next step is to gather some logs from your computer to check for any software or hardware conflicts and to check for any pending updates or software updates that may help.

If you would, please keep the dock connected to the computer with monitor(s) connected tot he docking station (even though one may not be working) and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to ‘support@plugable.com’ with the subject line ‘Ticket #345393 UD-3900PDZ - Attention Pat’ as this will allow us to examine some log files from your system to help determine the next steps.

Thanks,

Pat
Plugable Technology
support@plugable.com