Plugable USB 3.0 Malfunctioning


#1

My computer is indicating the docking station is malfunctioning. I have a HP laptop.


#2

Hi Robert,

Thank you for posting! I am sorry things are not working as expected with your docking station and I would be happy to help.

Based on your description of the behavior, our first step is to completely reset the dock and perform a ‘clean’ installation of the latest version we recommend of the dock’s required DisplayLink driver to help ensure both are in a good state. To do so, please follow these steps:

  1. Please disconnect the dock from the system and please disconnect the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep everything disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, please just move onto the next step.
  3. Download and run the DisplayLink Installation Cleaner utility, found here --> https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+8.4.2368.exe and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot the system (even if not prompted to).
  5. Now download and install the 8.6 M1 DisplayLink software driver, found here --> https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+8.6+M1.exe
  6. Reconnect the power cable to the dock first. Once the dock is powered on (a blue light will be present on the front), reconnect it to your system. If the device is not detected, please reboot the system.

Please let us know if that helps!

Thank you,

Bob
Plugable Technologies


closed #3

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.