Plugable usb 3.0 Dock Display Link not working via usb 3.0 port


#1

Running a gateway laptop windows 10 64bit. Installed displaylink drivers and whenever I plug in the dock into the usb 3.0 port of my computer, it doesn’t have the ability to project to a 2nd screen. When I switch over to a usb 2.0 port, it works fine. I was wondering if there’s a solution to this problem or if anyone else is running into the same issue. Thanks.


#2

Hi Nelson,

Thanks for posting. I’m sorry the dock isn’t working properly when connected to the USB 3.0 port. I’d be happy to help!

Thanks for testing the unit with both types of ports, that helps me a lot. One quick question, was the dock working properly on the same system with Windows 8? If it was we know the issue is most likely software related…

Pending that information, based on your description the cause may be a missing or corrupt USB 3.0 Host controller driver after the Windows 10 upgrade, or your system may have one of the rarer USB 3.0 Host controller chipsets that have been known to cause issues.

The best way to proceed is to have you run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug and send the file it creates to support@plugable.com with ‘Ticket 113236’ in the subject line so we can match everything up. Once we have the file the contents should tell us more details about the USB 3.0 components in your system.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

This is the same person that posted the original post. I’ll go ahead and do that tonight as I’ve been busy the past few days.

If anything, I also tried it on a second laptop running windows 10 that only has usb 3.0 ports and again, I run into the same problem where the computer doesn’t detect another screen to project to. I only got the plugable dock after I did the upgrade to windows 10 so I don’t have any experience getting the displaylink working on windows 8.


#4

Hi Michael,

Thanks for getting back with the update. Just send us the PlugDebug file when you have time and we’ll go from there.

Thank you,

Bob


#5