Plugable USB 2.0 to 10/100/1000 Gigabit Ethernet LAN Network Adapter dropped connection


#1

I recently purchased the above product for my Asus Transformer Infinity tablet, after plugging it in the tablet recognised the ethernet device and there was a link light and brief activity. But then all the lights went out and the tablet reported no wired connection. I tried the device on a PC and a Mac with the same results.

I have now returned (through Amazon) back to yourselves but would still like to use your product. So was this a faulty device (I assume so) or it there a known issue? I am worried about ordering another in case I get the same results.

Kind regards
David Senior


#2

Hi David, and thanks for contacting Plugable support!

The first thing that came to mind reading your post was that after the initial installation of the device and rebooting the tablet, we still need to go into system settings and enable ethernet- just like you turn on/off wifi and bluetooth.

As to why the device didn’t plug-and-play on your Mac and PC- both those platforms require a driver installation. Since you mention the link lights flashing, I suspect the device was working and just needed a little further configuration- unfortunately that is a little hard to troubleshoot without your having one in hand.

Please let us know if you decide to try another, we’re happy to assist with setup troubleshooting, we know the devices to work with Android tablets from some 5 star customer reviews on the product, and I use one with my tf300t all the time!

Thanks again for contacting Plugable support and best wishes-

Jeff Everett


#3

Hi Jeff, thanks for your prompt reply.

I did load both the Mac and PC with the latest drivers in each case and had the results I described. Which is why I was so quick to return the product because in all three cases the device was detected and for a brief few seconds seemed to work but then just stopped. I am keen to use this product and may re-purchase it in a few days time, just to see if it was just a faulty unit.
If I experience the same behavior I will let you know whilst still having the product to hand. I have read so many reviews of people with the Asus Transformer tablets enjoying your product and hope to be one of them soon!

Kind regards
David


#4

Oh by the way, I forgot to say, I did enable Ethernet in the settings, rebooted, unplugged, plugged back in - tried everything I could think! I work in IT and it had me baffled, I tried with DHCP and assigning a static address and the result was the same - an initial link and activity and then both lights went off and the connection dropped, never to return until rebooted and tried again. You can see perhaps now why I sent it back?!!

Regards
David


#5

Indeed David, if I went though all that I’d probably have returned the device as well!

Sorry to hear about your bad luck with that first device!

If you’d still like to try another one, please drop a line to support@plugable.com attention Jeff and we can work something out one-on-one that will hopefully be more convenient than having to order through amazon again.

One other situation I’ve seen is that some of the tablets don’t seem to provide enough power for the USB ethernet device to operate normally- one customer was able to get a stable and consistent connection only by running the USB2-E1000 through a powered USB hub. That doesn’t sound like it was the case for you since it sounds like you went though all the PC/Mac setup steps, but we’re more than happy to share the known problems/workarounds.

I hope this information is useful, and thanks for taking the time to post your experience here- we try and make as much of this information public as possible to help any others who might be seeing similar issues.

Again, thanks for sharing your experiences and best wishes!

Jeff Everett


#6

Yes I did see that some people were having success with powered hubs, but I ruled that out because I have the Asus keyboard dock with additional battery power and both the dock and tablet were 100% charged. Plus as you said I had the same problem with powered PC and Mac. I am beginning to think I was just unlucky and had faulty device! I will email you at the support address as I would like to give your product another chance.

Regards
David


#7