Plugable USB 2.0 Ethernet Adapter model : USB2-E1000 is not detected in Linux OS

Hi ,

I am using Linux OS and the latest kernel 3.4.20 . I checked the linux source files and they seem to have the desired file asix.c . So i assumen there is no issue with the driver. But I am using these adapters on an Intel atom processor and it fails to blink . The adapter is not detected and none of the lights blink .

Can be help me in knowing what is missing here. or if there is any compatibility issue ?


Hi Radhika-

Thanks for posting, sorry to hear your USB2-E1000 isn’t working properly.

Can you please post the results of the ifconfig command? I’d like to first verify if the adapter is listed in your network connections.

If you have a Windows XP or later system that’ll be a great way to test for a defective unit: drivers are automatically installed as long as the system is online and able to access windows update when the device is plugged in.

If you find the unit also doesn’t work in a Windows system, please send your Amazon order ID, device serial number (from the sticker on the unit) and a link to this thread to

Best wishes-

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies

thanks jeff.

the adapter works well on windows…below is the ifconfig output .

~ # ifconfig -a
ip6tnl0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
NOARP MTU:1452 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:806 errors:0 dropped:0 overruns:0 frame:0
TX packets:806 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:153306 (149.7 KiB) TX bytes:153306 (149.7 KiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wancom0 Link encap:Ethernet HWaddr 00:22:4D:81:A1:2B
inet addr: Bcast: Mask:
inet6 addr: fe80::222:4dff:fe81:a12b/64 Scope:Link
RX packets:21437 errors:0 dropped:41 overruns:0 frame:0
TX packets:657 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1701919 (1.6 MiB) TX bytes:100364 (98.0 KiB)
Interrupt:16 Memory:d0400000-d0420000

so basically the adapter is not detected here.

let me know whats that issue

Hi Radhika-

Thanks for verifying that the unit works, and that it’s not detected.

Can you share some details about the distribution you are running? Specifically, which package manager do you use? aptitude, debian based, etc?



I am running Linux 3.4.20 . I am not using any specific distribution like ubuntu etc here. I am running a software which uses linux 3.4.20 kernel.

Hi Radhika - Not certain, but it sounds like a kernel module or dependency may not be compiled into your kernel. Did you build this kernel yourself?

The code to support our adapter is here for 3.4.20:…

Our VID/PID is VID_0b95&PID_1780 which is there in the probe table.

As a next step, I’d double-check what’s in your kernel config …

yes i have the exact file in drivers/net/usb/asix.c

I did a diff between this file and the one i have in the kernel source …and they are exactly same.

Hi Radhika - Yep, the file is always going to be there (because it’s part of the Linux kernel) – but that doesn’t mean it’s compiled in, if it’s a custom kernel build. Make sure to have USB_NET_AX8817X and dependencies enabled in the kernel config:

config USB_NET_AX8817X
tristate “ASIX AX88xxx Based USB 2.0 Ethernet Adapters”
depends on USB_USBNET
select CRC32
default y

Here’s more detail on compiling kernels:…

But just generally, you’re into a very complex area. Other than for very advanced users, you’ll want to use a standard distro with pre-built kernels (and all the major distros have this driver enabled by default). Going off the beaten path with a custom kernel makes it very difficult for others to know what’s going on …

ok great. thanks for all your help . I will try this thing