Plugable USB 2.0 Ethernet Adapter doesnt work with Ubuntu 12.04


#1

I purchased Plugable USB ethernet converter and it doesnt work. I tried it with windows 7 and ubuntu too, no help :frowning:
I installed the drivers from the asix page, and it doesnt seem to work.

This is the ouput of my lsusb:
lsusb | tail -1
Bus 002 Device 005: ID 0b95:7720 ASIX Electronics Corp. AX88772

I tried my friend’s usb to ethernet (not a plugable one) which used to work before, but doesnt seem to work any longer.

Can someone help me with this please?


#2

Hi Richa-

Thanks for posting with your issue!

For troubleshooting purposes, I’d recommend focusing on your Windows PC. Ubuntu support is no issue, but troubleshooting can be faster on Windows so let’s focus there and make sure the device is still working normally.

On Windows, you should be able to see a similar AX88772 device under device manager.

Can you please say if the device is listed here under network devices, and mention any error codes you might see under details here?

One of the reasons I recommend troubleshooting on Windows is that it should automatically download and install the driver via Windows Update so long as the PC is already online when you plug the adapter in.

With these extra details I’m confident we’ll be able to get you up and running.

Best wishes-

Jeff Everett
Plugable Technologies


#3

Yes, I see a device AX88772 listed under Device Manager in windows 8. I dont see any error codes too. But, the two leds doesnt seem to power on and the device doesnt work either.


#4

It works now. Thanks,


#5