Plugable UGA-2K-A multiseat with LightDM


#1

I am currently trying to set up a multiseat environment with a Plugable UGA-2K-A and internal Intel graphics under Ubuntu 12.04 LTS Beta with LightDM. If I use autologin everything works fine but without it is not possible to login because the password fields are not shown in greeter.

See also this bug report: https://bugs.launchpad.net/ubuntu/+so…

Did anyone successfully configure LightDM multiseat with Plugable UGA-2K-A ?


#2

Hi Fabian,

Thanks for posting. That’s a great fixed-device static xorg.conf multiseat setup you’ve done. Great job!

Based on the errors in 0-greeter.log, I’m wondering if the issue might be the same one solved by the “xrandr -o 0” command in step 7 of the old Ubuntu 9.04 instructions: http://plugable.com/2009/11/16/settin…

This sets the orientation of the screen to “normal” and solved issues which sound vaguely similar to what you’re seeing (but I’m not confident, because much has changed since then).

Can you try that and let us know if it helps?

Thanks!
Bernie


#3

Hi Bernie,

Thanks for your fast answer!

The xrandr-workaround is already executed by my lightdm-configuration, see the following line in lightdm.conf:

display-setup-script=/usr/local/bin/dl-workaround.sh

The dl-workaround.sh script executes “xrandr -o 0”, see also the following bug-report
https://bugs.launchpad.net/ubuntu/+so…

So this is not my problem…

Thanks,
Fabian


#4

Hi Fabian,

I’m not sure what the problem is - I assume lightdm is rendering the textboxes at login in a special way.

One thing to try is using the “fbdev” X server with defio enabled, rather than the “displaylink” X server. It’s slower but not dependent on X DAMAGE protocol notifications.

Here’s how: http://plugable.com/2011/12/23/usb-gr…

Can you let us know if that helps?

Bernie


#5

Thanks for your suggestion, I will try this later this week, I currently do not have access to the machine.


#6