Plugable UD-CAM - 2017 MacBook 12" does not detect external display (ASUS VN279QL)


#1

I have the Plugable UD-CAM which I use with a 2017 MacBook 12-Inch and an ASUS VN279QL monitor and a standard HDMI cable. The MacBook does not detect the external display through the dock. I tried this with a travel hub with HDMI and it functions correctly.

To connect the MacBook to the dock, I tried using both the USB-C cable that came with the UD-CAM as well as the Apple USB-C cable.

I tried installing the DisplayLink driver from Plugable’s support page, but a notification came up stating that the MacBook had a version that was more recent.

How can I get the UD-CAM to work with this setup?

Thank You!


#2

Hi Philip,

Thank you so much for reaching out to us, I am sorry to hear that you are running into this issue, but I would be more than happy to assist!

The UD-CAM can only be utilized with very specific USB-C cables, due to the features of the dock. The Apple USB-C cable does not allow for Power Delivery, VESA Alt-Mode, and Data via the same connection, so this may not have been a needed test, but I appreciate you trying it out.

Thank you for sending over the specifications of your display, this can always help a lot when attempting to isolate the issue down. Based on the specification of the display, it should be compatible with the docking station, as long as a direct HDMI to HDMI cable is being used (which I think you confirmed by saying “standard HDMI cable”)

The UD-CAM is driverless, and does not utilize DisplayLink based chipsets to output to a connected display, so the driver installation is not required. Due to recent incompatibility issues with the current macOS update in 10.13.4+, I would advise uninstalling the DisplayLink drivers, just to make sure this is not causing any communication issues.

When the dock is connect to your system, does the indication light on the front activate once the power button is pressed? Do the USB ports and Ethernet function, while the HDMI port is not functioning?

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Hi Everyone,

We attempted to reach out to Philip to obtain some additional information regarding his configuration, as well as provide some specifics regarding the product they were using, but we did not receive a response back.

If Philip, would like to continue troubleshooting, or anyone else is running into the same issue, please feel free to reach out to us directly at support@plugable.com.

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#4

Apologies for the late reply.

The light does turn on when the dock is plugged in. I haven’t yet had a chance to test the dock since I wrote the initial inquiry, but I will work with it tonight and report back

Many Thanks,
Philip