Plugable UD-3900 not working after driver update


#1

Yesterday I performed an update to the DisplayLink driver software and now one of my two external monitors is no longer recognised.

I am using a Surface Pro 2 connected to a UD-3900 device with HDMI and DVI outputs. The DVI output no longer seems to be working since the update as connected to either monitor it doesn’t work. I have tried rolling back to older driver versions and this no longer works either.


#2

Hi Chriss,

Thanks for posting! I’m sorry the dock stopped working properly with your Surface after the DisplayLink driver update. I’d be happy to help!

Since the problem occurred after the driver update, the first step to clean the DisplayLink driver completely from your system and re-install the latest version we recommend. Please follow these steps:

  1. Disconnect the dock from your Surface and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step

  3. Download, extract and run the DisplayLink cleaner tool, found here:
    http://displaylink.com/support/sla.ph…

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and run the 7.7 M4 DisplayLink software, found here:
    http://displaylink.com/support/sla.ph…

  6. Reboot, even if not prompted to

  7. Once you’re back in Windows, reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your Surface which will trigger the final portion of the installation

Hopefully that gets the DVI output working properly. Let us know the results when you have a moment and we can determine the next steps from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

Hi Bob

Thanks for your prompt response.

After following these steps unfortunately the monitor is still not being recognised.

Chriss


#4

Hi Chris,

Thanks for getting back to us! I’m sorry the driver re-install didn’t get everything going. The next step would be for you to run our diagnostic program PlugDebug --> http://plugable.com/support/plugdebug and send the file it creates to support@plugable.com with ‘Ticket 104465’ in the subject line and your Amazon Order ID number for the dock in the body. Once we have the PlugDebug file we can determine the next steps from there.

Thank you,

Bob


#5

Hi Bob

I have now sent the required file.

Chriss


#6

Hi Chriss,

I received the file and I am looking at the logs now.

Thank you,

Bob


#7