Plugable UD-3900 interfering with VPN connection


#1

Just got a Plugable UD-3900. I connected it to my Surface Pro 3 (running 8.1 Pro). After that, I ran into problems using Dell SonicWall Global VPN Client (version 4.9.0.1202). When my Surface Pro is disconnected from the dock, VPN connection works fine. Connection only gets buggy when dock is connected. I’ve installed the latest DisplayLink drivers. Still having problems. Thoughts?


#2

Hi Ricardo,

Thanks for posting. I’m sorry the VPN connection isn’t working as expected with the dock. I’d be happy to help.

Can you elaborate on how the connection “gets buggy when the dock is connected”? Does is no longer connect at all?

We haven’t had any specific reports about a conflict the drivers for our dock with the Sonicwall VPN client.

Let’s try removing the drivers for the dock, testing the VPN, re-installing the drivers for the dock and test the VPN again. Please follow these steps:

  1. Disconnect the dock from the computer and please remove the power cable from the dock so it turns off completely.

  2. Uninstall the DisplayLink Core software from Control Panel->Programs. Don’t worry if this fails, just move onto the next step

  3. Download and run the DisplayLink cleaner tool, found here:
    http://displaylink.com/techsupport_fi…

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Test the VPN

  6. Now download and run the 7.7 M2 DisplayLink software, found here:
    http://displaylink.com/support/sla.ph…

  7. Reboot, even if not prompted to

  8. Once you’re back in Windows, reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your PC which will trigger the final portion of the installation

  9. Test the VPN again.

Please let us know if that helps, and we can go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3