Plugable SuperSpeed USB 3.0 Docking Station - drivers/modules not all installing, displays flash and wireless mouse/keyboard won't work


#1

I just bought the plugable SuperSpeed USB 3.0 Docking Station. Each time I try to install the drivers and control panel (or what I think will be a control panel) - I’m loading DisplayLink 7.20 - it fails to install three of the necessary modules (two of which are called Plugable USB 3000). No matter what I do I can’t make these install, and the dock does NOT work properly (my displays on both my laptop and external monitor flash on and off and the wireless mouse and keyboard will not work; neither will the speakers). I’m running Windows 7 with all the latest Windows updates. Needless to say, I’m not pleased. I work in IT and am quite tech savvy but I’ve been fighting with this for two hours; this should be plug-and-play. What’s up?


#2

Hi Jessica,

Thanks for posting your question here sorry to hear about the install difficulties with the Plugable UD-3000 docking station. I’ll be happy to help.

I’d like to have you run the DisplayLink Support Tool and forward the log files over to us at support@plugable.com for analysis. Once we get a chance to look at the details in the log files, we’ll be able to determine the best next steps to get you up and running.

Here’s a link with instructions on how to run the Support Tool.
http://plugable.com/support/tools/dis…

Along with the log files please include your Amazon order id, the serial number from the unit you have and a link to this post.

Thanks!
Jerome.


#3