Plugable DisplayLink quit working


#1

My Plugable DisplayLink device was working great for 9 months until today. A system program on my Dell Inspiron Ultrabook running Windows 7 automatically updated an Intel graphics driver and after the installation the DisplayLink wasn’t being recognized by the laptop. I uninstalled the DisplayLink graphics and software, then reinstalled them from the CD. I also downloaded the latest drivers from your site. Still no luck. Any ideas??


#2

Hi Robert,

Thanks for getting in contact with us. I’d be more than happy to help you with your Plugable display product. In order to better assist you, I’ll need a bit of additional information.

First, can you please try reinstalling the DisplayLink drivers by following these steps:

  1. Disconnect the adapter from the computer.

  2. Run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  3. Download driver v7.5 M1 from the below link and follow the installation prompts.
    http://displaylink.com/support/sla.ph…

  4. Reboot the computer.

  5. Replug the adapter to the computer. Allow several minutes for the driver to enumerate and for the firmware upgrade to complete.

Then, can you please provide the logs produced by our tool Plugdebug, you can find it here and then send them to me at support@plugable.com.

http://plugable.com/support/plugdebug

Once we have those logs, we’ll start trying to figure out what exactly is going on with your setup.

Regards,

Stephen
Plugable Technologies


#3

Stephen - Thank you for your reply. As it turned out, the problem is not with the Plugable device. Whatever happened with the driver update disabled both the 2.0 and 3.0 USB ports on my laptop. No device is recognized when anything is plugged into those ports. I tried reinstalling the Intel driver that I think was being updated, but that didn’t work. I am going to contact Dell to see if they have an easy fix (before I have to take the laptop to a repair shop).


#4