plugable Display adapter stopped working on USB2.0 Docking Station


#1

it worked perfect from day one and generally worked great.

For a few months though the monitor hasn’t worked at all. I can disconnect/connect the power and/or USB and it never makes a difference. The green light never comes on.

I’ve tried plugging it into the docking station and also directly into the laptop. all the usb ports seem to be working fine for all other applications…


#2

Hi!
Thanks for posting and sorry to hear that the UGA-2K-A seem to have died !

Just to make sure it’s no computer related issue - can you try testing the device on a different computer and see if the light will come up ?

If that doesn’t help we can send out a replacement as soon as possible!

All we need is:
a) Your Amazon order ID
b) the Serial Number of the device (to be found on the back of the device on a sticker)
c) your current valid address to send the replacement to

Once we have this information we can suggest next troubleshooting steps or send out the replacement!

Regards,
Lampros


#3

Hi!

I saved your information and deleted your post - My apologies, should have mentioned that you need to e-mail that information to us.

Can you please e-mail us at support@plugable.com so we can get your e-mail address as well ? Just mention your order ID in your e-mail and we’ll take care of you.

Regards,
Lampros


#4

Hi Lampros,

Thx againfor your help. I received the new unit and it worked fine at first. I sent the old unit back to your team.

But the new unit started acting up within a week or two. Then it became unusable. It seems like maybe a driver issue this time though.

Right now I have a laptop on a docking station, plugged into a second monitor using the VGA input.

When I plug in the plugable unit, then screen 2 goes blank and then eventually turns off. screen 3 (the one conencted by Plugable) shows my wallpaper, but not my desktop or start menu, or desktop shortcuts…

I tried a windows update to no avail…

I have been too slammed to try to fix this, but now realizing I just need to make some time.

Should I maybe reinstall the plugable software?

Thanks,

JOhn


#5

Hi John,

Thanks for posting! Sorry to know about the trouble you are having in getting all the monitors to display the way you want it to. Let’s first set the ‘Extend’ mode for multiple monitors and see if it fixes the issue.

Press the Windows logo key + P on your keyboard. A window pops up with 4 options - Computer only, Duplicate, Extend, Projector only. Select Extend to extend the display across multiple monitors.

Does the second monitor turn back on?

Let us know and we will figure out the next steps.

Regards,
Roze


#6

HI Roze,

Thansk for getting back to me so quickly! Much appreciated.

when I have the laptop (screen 1) and screen two on, and press controp P, it is already set to extend.

when I then plug in the plugable, same problem as before. (Screen 1 is completely blank, save for the cursor, and screen 2 goes off, and screen 3 (the one with the plugable connection) just has the wallpaper and nothing else.

when I then press control P nothing happens

… next steps?

Thansk,

John


#7

John,

You mentioned that screen 1 which is the laptop monitor is blank except for the cursor. If you move your mouse can you see this cursor move on the laptop monitor?

If yes, if you try to move the cursor beyond the edges of the laptop monitor, does the cursor move out of the screen?

If yes, if you keep on moving the mouse, does the mouse cursor appear on the screen 3 (the one connected through the Plugable Graphics Adapter) ?

Once you post back with this information, we will figure out the next steps.

Regards,
Roze


#8

hi Roze, yes, yes, yes. Of note, screen 1 is on the far right, screen two inthe middle, and screen 3 on the far left. in the situation we are talking about, the cursor goes directly from screen 1 to screen 3, as if screen 2 (the one that turns off) does not exist. I guess that makes sense. Thanks, John


#9

Hi John,

Alright! Now that we know that the mouse cursor does come on screen 3, let’s try to get the Screen Resolution control panel to display on that monitor and check the settings. To do that on Windows 7 -:

Move the mouse cursor to screen 3 where you can see the wallpaper. Right click on the desktop and select ‘Screen resolution’ by clicking on it. If the Screen resolution control panel does not show up on that screen (it most probably might not), press on the Windows key (not the ctrl key but the key with the windows logo on it) and while keeping it pressed, keep clicking on the left arrow key (since screen 3 is on the left of screen 1 where the Screen resolution control panel might have opened) until the Screen resolution control panel moves to screen 3.

Once the Screen resolution control panel shows up on screen 3 select each display listed one at a time and make sure that ‘Extend these displays’ is the mode set for ‘Multiple Displays’. Click on ‘Apply’

Do let us know if the other two displays showed up. If not, please do post back and let us know what modes the Windows Screen Resolution control panel is listing for each display. We will take it from there.

Regards,
Roze


#10

Thanks Roze,

nice trick!

I tried that and indeed needed to do windows left arrow. All three monitors were set to “extend this display”. I tried making monitor 3 the main display instead of monitor 2, but that did not help.

next step?

Thanks,

JOhn


#11

John,

This is highly unusual! Could you run the DisplayLink support tool (instructions here: http://plugable.com/support/displayli… ) and email the .zip to support@plugable.com.?

This would give us a better insight as to what is going on. You can unplug the Plugable UGA-125 before running the DisplayLink support tool.

Once we analyze it, we can figure out the next steps.

Regards,
Roze


#12

Hi Roze,

I sent it. I did it with the Plugable unplugged.

Thanks,

John


#13

Hi Roze,

the suggestion you made to me in e-mail worked great! (I think it was the updated graphics driver that did the trick)

Do you want to post that here for others?

THanks so much!

-John


#14

For the benefit of anyone who is interested-:

The logs generated by the DisplayLink support tool indicated that John had very old drivers for both DisplayLink as well as his primary graphics card. Updating the drivers to the latest versions fixed the issue for him.


#15

also, I was using the windows basic graphics setting in Windows 7. I think that plugable requires you to be using an Aero setting.

Roze, at some point I might ask you what parts of the Aero setting need to be turned on for plugable to work. The setting is a cpu hog and does slow down performance noticeably.

Thanks again!
-John


#16

John,

If Aero is disabled on Windows Vista/Windows 7, the OS automatically disables the Desktop Window Manager which many of the latest display drivers (including ours) depend on to render graphics.

I understand that with Aero enabled, the CPU utilization is more than when Aero is disabled. But Aero is not just providing a fancy look, it provides a cleaner, more powerful, more efficient way of rendering graphics. When Aero is disabled, Desktop Window Manager is turned off. With Desktop Window Manager turned off, you would see screen freezes and sometimes black display.

When Aero is disabled and you run the Windows aero troubleshooter, it will report that it had found Desktop Window Manager disabled.

The DisplayLink Drivers that are installed for the Plugable USB Graphic Adapters to work depends on the Desktop Window Manager for rendering Graphics on the connected monitor. So you absolutely do need to have Aero enabled for any of the Plugable USB Graphic Adapters to work without issues. It will not work in Basic mode. Sorry about that!

Hope the above information helps! If you need any additional information or help regarding any of our products, feel free to post here or to shoot us an email at support@plugable.com. We are here to help!

Regards,
Roze


#17

thx rose, very helpful.

with aero on, i went into system proporties and unclicked all the aero functions:

similar to: http://www.howtogeek.com/howto/5473/m…

now it looks like I have the Desktop Windows Manager rnning, but not all the visualizations. so far soo good. we’'l see after I reboot…


#18

HI Roze,

something odd happened last night at home with my computer on the docking station. and it went blank, could not revive, woudl not undock, and I needed to manually reboot it. When I arrived at work I had the same problems as before.

To troubleshoot. I turned on a default aero theme, no help. uninstalled and reinstalled Plugable. No help. Then I made monitor three the main display, and then changed the resolution of monitor two (the one that was turning off because it was not getting an input). this made it work!

I’m writing thise here to refer to it again if the problem arises inthe future. while I am at it, I’ll paste your message to me from support @plugable. scrub/edit it as appropriate.

Thanks again,

JOhn

Hi John,

Thanks for sending the logs! The main Graphics driver as well as the Displaylink drivers are all very old versions. You need to install the latest drivers.

  1. First download and install the latest drivers for your Primary Graphics Card-:

The latest drivers for Intel HD Graphics Driver for Windows 7 (64-bit) for your laptop ( LENOVO - 2985F4U ) can be downloaded via the following link -: http://support.lenovo.com/en_US/downl…

  1. After restarting the system after the installation of the Intel drivers, let’s try to uninstall old versions of DisplayLink drivers and do a clean install. Here are the steps for that-:
  1. Click on the following link to download the DisplayLink install cleaner. http://displaylink.com/techsupport_fi…
  2. Once the download is complete, unzip the downloaded file and run the DisplayLink install cleaner.
  3. Download the latest DisplayLink driver 5.6M1 from http://www.displaylink.com/support/do… and run it to install this driver.
  1. After installing the latest DisplayLink driver, please run theWin 7 Aero troubleshooter and see if that identifies/fixes any problems and helps? http://windows.microsoft.com/en-US/wi…

Currently the logs say that Windows Aero is disabled. If Aero is disabled on Windows Vista/Windows 7, the OS automatically disables the Desktop Window Manager which many of the latest display drivers depend on to render graphics. So please ensure that Windows Aero is enabled.

After installing the latest drivers and ensuring Aero is enabled, connect the Plugable UGA-125 and check if the issue still persists. If it does,please run the DisplayLink support tool (instructions here: http://plugable.com/support/tools/dis… ) and email the .zip to us. This will help us in confirming if the changes have been made on the software side and what else could be causing this unusual issue.

Please also let us know if the issue has been fixed.

Looking forward to your reply!

Thanks!

Regards,
Roze (roze@plugable.com)
Plugable Technologies

Thanks again!

-John


#19