Plugable caused conflict w/ DaVinci Resolve 17

I’ve been struggling with upgrading to DaVinci Resolve 17 from 16. (Windows 10 Home 21H1 x64; 16 GB DDR4-2400 RAM; MSI H270 Gaming Pro Carbon; Intel Core i5-7500 @3.4GHz; AMD Radeon RX 570). Clips in the media pool wouldn’t show thumbnails and wouldn’t play. Resolve said it was only getting 1.5 fps. After a day of updating and uninstalling and reinstalling and tweaking settings, we noticed in Device Manager that there was a second graphics adapter showing and it was that “graphics card” that Resolve was trying to use…it was the Plugable UD-3900. So we removed it from Windows Device Manager and Resolve began working fine. So bad news…the Plugable was really messing with Resolve 17 and there were few indications what was wrong; good news…a Plugable can render 1.5 fps!

Hello,

Thank you for sharing your experience in our forum!

The Plugable UD-3900 docking station is based on DisplayLink technology, which is in essence a ‘virtual’ graphics adapter (also known as a graphics processing unit or GPU) that relies on the host system’s CPU and internal physical graphics processing unit (GPU) in order to generate the image shown on the dock-connected monitors.

Some applications can get confused by the presence of a ‘virtual’ graphics adapter, and mistakenly attempt to send tasks intended for the physical GPU to the virtual device. Since the DisplayLink device is not a physical GPU, this can result in unexpected behavior.

If you remove the ‘Plugable UD-3900’ device from within Device Manager, the most likely result is that the monitors connected to the UD-3900 will no longer function.

While we cannot guarantee the result, a possible alternative solution may to be change the ‘Preferences’ settings within DaVinci Resolve in regard to which GPU is in use to see if that changes the behavior:

  1. Within DaVinci Resolve, please click on the ‘DaVinci Resolve’ item from the File menu, and then select ‘Preferences…’

  2. Once within ‘Preferences’, click on the ‘Memory and GPU’ option from the choices on the left-hand side of the window. Make sure that ‘System’ is selected from the tab at the top of the window.

  3. Under the ‘GPU Configuration’ section, uncheck the ‘Auto’ box next to ‘GPU Selection’.

  4. Given the specifications of your setup, you will most likely see three GPUs listed in the table under GPU Selection. One GPU will be the ‘Intel HD Graphics 630’ GPU that is integrated into your Intel Core i5-7500 processor. One GPU will be the AMD Radeon RX 570 GPU you have installed in your desktop system.

The remaining GPU entry will most likely represent the ‘virtual’ GPU in the form of the UD-3900. It may not be named ‘UD-3900’, and may have a name that mirrors one of the other GPUs in your system. One detail that should help identify it is that under the ‘Memory’ column in the GPU table the value should be ‘0.0 GB’.

  1. Click to remove the check mark next to the GPU entry within the GPU table that represents the UD-3900 docking station.

  2. Click the ‘Save’ button at the bottom of the window to save the changes.

  3. Close the DaVinci Resolve application.

  4. Restart the DaVinci Resolve application. Confirm that the changes you made within ‘Preferences’ have been retained.

  5. Test the rendering behavior again

While I do not have the same hardware setup, I captured a screenshot from my own test system that shows the above changes having been made and have included it inline below. In my case, my laptop has one physical Intel Iris Xe GPU built-in to the laptop. This is the entry that has a value of ‘3.0 GB’ in under the memory column.

The second GPU that represents the UD-3900 dock connected to my system is mis-labeled with the same name as the physical GPU, however the memory value is ‘0.0 GB’.

Apologies again for the frustration, and thank you again for sharing your experience in our forum!

Bob
Plugable Technologies

1 Like

Thanks for the quick and thorough reply. I did look at the Memory and GPU tab of the Resolve Preferences and it showed only the Radeon card and I did take it out of Auto and try to force it to use the Radeon card listed. Unfortunately I don’t remember what it showed for memory under that listing, it might have been 0.0GB. I should have thought to check the Device Manager earlier.

I don’t have any other monitors plugged into the Plugable right now so I’m not going to lose that functionality. I did when I had a wimpier graphics card w/o a second monitor plug. When I got this one I started with one monitor plugged into the Plugable but it caused all kinds of havoc with the two monitors (which, to be fair to the Plugable, were old stuff I had lying around).

Interesting that Resolve 16 worked fine and it was the upgrade to 17 that surfaced the issue. Maybe related to how DaVinci solved 17’s problems with AMD cards? You should have heard my son pretending to be DaVinci…“Let’s see, for rendering this 4KHD video I’ll need a GPU. I could use this pretty decent Radeon card or this USB Dock…I know, I’ll use the USB Dock.”

Thank you for getting back to us with the updates, and you are of course most welcome for the information.

Given your experience, I believe it is fair to say that ‘something’ has changed in the new version of DaVinci Resolve in terms of how it deals with the presence of ‘virtual’ graphics devices. However, since the application is outside of our control I am afraid that we cannot be sure as to the specific cause or why your system differs from our example.

Looking back, I realize now that previously I did not implicitly state that configuring things in the manner I described allowed Resolve to render a simple timeline at a speed expected with my test hardware. To put that another way, the presence of my UD-3900 on my test system did not appear to negatively impact the performance of the Resolve application.

A quick search within the Blackmagic Design forums results in a few cases where others have reported unexpected behavior while using DisplayLink-based devices, however BMD’s responses all tend towards ‘disconnect the DisplayLink device’ as opposed to digging further into the issue.

Outside of further adjustments in regard to the DaVinci Resolve GPU preferences, the only other element to check (if you have not already) is that the drivers for your both your integrated Intel GPU and discrete AMD GPU are up to date with the latest versions.

Outside of those elements, since we do not have identical hardware to try and replicate the behavior I am afraid we do not have any solutions to offer.

Apologies that we could not be of more help in this specific case, and thank you in advance for your understanding!

Bob

1 Like

Very useful thread.
I came here because my wife found she couldn’t launch DaVinci Resolve when her PC was connected to her UD 3900. She’s using a Japanese language version, but the message said effectively that the program couldn’t find any valid GPU. First thread that caught my eye happened to be this one, which struck me as miraculous. Wife’s Resolve is version 16 but she was having problems anyway.
I fiddled with the settings, switching GPU processing mode from Auto to OpenCL, since this was the only choice that produced a GPU in the list below. The only other alternative, CUDA, produced nothing, so this might have been the docking station’s virtual GPU? I also set GPU selection to Manual, and ticked one of the two Intel GPUs listed. These settings did the trick. The program language is Japanese, so the attached image file may be difficult to grasp, but I’ve attached it anyway just in case it’s useful. Thanks again to everyone who contributed to this thread! Won me a couple of brownie points from dear wife.

Hi Jeremy,

Thank you for sharing your experience with our community!

We appreciate the detail you provided, and I am glad that the information in my earlier post was helpful in your particular case. Hopefully this experience will also be able to help others moving forward :slight_smile:

Thank you again for adding to the discussion!

Bob
Plugable Technologies

1 Like