Plugable adapter disables 2nd display from video card.


#1

After installing the Plugable USB video adapter to support a third monitor on Windows XP, every time I reboot, the second monitor (connected directly to the Nvidia video card) is disabled, and its position relative to the other monitors is moved.
The Plugable driver also relocates all of my desktop icons, even the ones placed on the main display.


#2

Hi !

Thanks for posting and sorry you’re seeing this problem!

The problem with Windows XP is that the menus for controlling multiple Display Adapters are not as unified as with Windows 7 and that can make things harder.

NVidia has their own utility to bypass the Windows display settings and then DisplayLink (our Plugable product) has it’s own little menu as well.

Some questions to help us isolate the problem:
* What laptop/desktop model do you have?
* Specifically which NVidia graphics card do you have and which Plugable product?
* So far, how are you configuring the multiple monitors? Are you using the DisplayLink icon on the taskbar or through the Nvidia Control panel?
* Which version of DisplayLink drivers are you running?

As soon as we have this information we’ll be able to suggest next troubleshooting steps!

Regards,


#3

The computer was built on an ASUS motherboard with an AMD processor.
The video card is an Nvidia 7300GS with one DVI connector and one VGA connector. It has the current drivers installed. I do not have the NView desktop manager enabled.
The Plugable adapter is the UGA-2K-A.

The Nvidia control panel only sets the 2nd monitor for on/off or clone/extend and resolution. I have to use the Windows display properties to arrange the layout of the displays.

The displaylink is the same for the third display and takes me back to the Windows display properties for arrangement. The driver appears to be 6.12.10.502


#4

Thanks for that information!

Just to clarify, once the computer starts up, the 2nd monitor is disabled ?
Can you then enable it ? After enabling it and you reboot, it’s disabled again?

The relocation of icons usually happens when a monitor is disconnected. It sounds like the display settings are not preserved after rebooting.

Regarding the DisplayLink drivers, can you:
Click Start, and then click Control Panel.
Click Performance and Maintenance, and then click System.
Click the Hardware tab, and then click Device Manager.
Once there, click on ‘USB Display Adapters’, you should see something like ‘Plugable UGA-2K-A’. Right click on that and click Properties, then click on Driver.

What is the Driver Version listed there?

Regards,


#5

I chose my words in the original post carefully and they are accurate: “every time I reboot, the second monitor (connected directly to the Nvidia video card) is disabled” For the second monitor to “disabled” on reboot it had to be “enabled.” The term “every time” necesarily means this cycle occured more than once.
The desktop icons on the primary display are moved on reboot. Those along the top of the screen move to the left side.

The USB Display adapter driver is 5.5.29055.0
The Displaylink driver version is 6.12.10.502


#6

Thanks for clarifying!

The first thing we would suggest is to try and update to the latest DisplayLink driver. The driver available through Windows Update is 5.5. From the DisplayLink website you can get the 5.6 M1 (latest at the moment). You can download drivers here.

Similar problems have been reported before on forums regarding NVidia cards not holding on to their settings after reboot - driver updates seem to be the most common solution. What is the NVidia driver you are currently running? Can you try to update to the latest NVidia driver. You can download them here.

Let us know if this helps!

Regards,


#7

After updating the Displaylink driver to the one from displaylink.com rather than Windows Update, the second moniter was still enabled on a restart and the desktop icons were where I placed them on both displays.
The updated driver does look like it resolved this issue.

The product instruction sheet that says “allow Microsoft’s Windows Update to automatically download the latested driver” should probably be changed.

Thank you for your help.


#8

Hi!

That’s good news!

Thank you for the feedback regarding the instruction sheet. It definitely needs to be changed and we’re already working on this.

Regards,
Lampros


#9