Plugable 7 Port High Speed USB 2.0 Hub doesn't power the raspberry


#1

Hello, I recently purchased your Plugable 7 Port High Speed USB 2.0 Hub . In your youtube video I saw the raspberry connected to the hub and gives energy to it. I tried three different usb micro cable but doesn’t power the raspberry. Is there any trick? What am I doing wrong?


#2

Hi Toni,

Thank you for posting your question about using the 7-Port hub with your Raspberry Pi. I’m sorry to hear you’ve been having difficulties with it. The Pi should work with the hub without any special trick, so I would like to do some troubleshooting so we can find out what is wrong.

When you plug the AC adapter into the USB hub, does the red light come on?

When you plug in the Pi to the adapter, does its red light come on? Is there any difference if you try different ports on the hub?

Have you tried powering the Pi from another source, just to make sure the Pi is OK? For example, I power my PI from the charger that came with my Android cell phone. Typically, any cellphone changer that outputs to a micro USB jack should work.

Thanks for working with us on this.

David
Plugable Support


#3