PC stops detecting external monitors after upgrading to Windows 10


#1

I have a Dell XPS 13 that was shipped with Windows 7. It was purchased in July 2014 and has served me very well and still performs brilliantly. I have been very satisfied with a USB 3.0 Dual Head Display adapted (model WS-UG39DH1 Rev A), which I bought at the same time since the laptop has no ethernet port and to avoid needing to carry lots of cables. It has served me very well in a wide range of situations - monitors of various makes, projectors and televisions. This was also in Windows 8 which I had on the laptop for a time. I have now upgraded to Windows 10. Unfortunately since doing this, whilst the network port still provides me with a wired connection, the PC has stopped detecting any external monitor/projector. As a result of this I bought a new one, thinking it had broken (model USB3-3900DHE) but with the same result, which points to the hardware or Windows itself. When I use the mini display port everything works OK. I have tried DVI, HDMI, and DVI with the VGA adapter. I have upgraded the driver to the Beta 8 version, still nothing. I work in software and IT so hope that I have done everything right. Help please.


#2

When I plug a monitor into the DVI port of the dual head multi display adapter it says it is not getting a signal. I have made sure that I have asked Windows to extend (and also tried to duplicate) the display, but it doesn’t detect the monitor. I have now gone into the Services console and realised that the DisplayLinkManager service is not running. Trying to start the service gives me an error ‘Windows could not start the DisplayLinkManager service on the local computer, Error 1067 the service terminated unexpectedly.’


#3

When I run the DisplayLinkManager.exe as Administrator (it doesn’t run otherwise) then a system tray icon finally appears which I have read about but never seen. This informs me that ‘No DisplayLink devices detected’. I have tried plugging the dual head display in again, and into different USB ports, still nothing.


#4

… but the network port is working so I know it is connected.


#5

Please see my direct response.


#6