Partitioned drive "not readable" in U3 USB dock but works fine in old enclosure (Mac OS X)


#1

I have a 3TB drive with three partitions that has lived in a slowly dying enclosure. I pulled it out carefully and have tried it with USB 2.0 and USB 3.0, but always get an error that the disk is unreadable. I thought I zapped it, but put it back in the old enclosure and everything works a-ok. I tested the USB cables and they’re fine.

I read a comment on Amazon that this happened for another person as well… he said his disk needed to be reformatted within the dock, then it worked like a charm. Anything I can do short of this solution to save me from having to backup the data from the (slowly dying!) older enclosure to another drive?

Thanks!


#2

Hello,

Thank you for contacting Plugable support! I’d be more than happy to assist you with this issue.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the device into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Plugable Technologies


#3

What was the outcome? I am experiencing the same issue with an already formatted drive full of data I need!


#4