paradise lost - want to re-establish mulktiscreen display


#1

We are very pleased with the USB 3.0 Docking Station. It has worked for us flawlessly. Suddenly, both monitors have stopped getting signal. They have power and are turned on, the connection to the docking station is tight. Suggestions?


#2

Hi Michael,

Thanks for contacting us. Sorry to hear that our dock stopped working with your monitors and I will be happy to help!

Thank you for the description of the behavior you are seeing. Based off of this, we will want to reinstall the DisplayLink software and run the DisplayLink cleaner tool to make sure that the software is in a good state. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. (If running Windows 10) Run Windows Update (Start > Settings > Update & security). Reboot if/when prompted. Repeat this process until there are no new updates found. This is important as Microsoft has been releasing frequent updates to Windows 10.
  6. Now download and install the 7.9 M7 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  7. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system when prompted by the installer which will trigger the final portion of the installation

If that helps, great! If not, we’ll want to examine some log files to see if they can tell us what is happening. To help us do so please download and run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug with everything connected. When the utility completes it will notify you a file has been created and provide our direct email support address to send the file (support@plugable.com). Please send the file to that address with ‘Ticket 145509’ in the subject line so we can match everything up.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3